-2

A few days ago my old system died, so I moved the hard drive into a new system (one and then another, actually, as I was trying to piece together the best system from old spare parts). Of course, it says I need to reactivate Windows (no surprise there). However, when the 'you need to activate' window comes up (every few hours) and I click the link, it just goes back to the desktop without activating. When I go to the System section in the control panel (Properties on 'This PC'), there is an 'Activate Windows' link there. When I click it, the window starts to shrink as if it's going to open another window, but then just goes back to the same window. There is a purple 'PC Settings' application now showing in the taskbar. When I click that, the transition animation appears with a purple screen with a white gear on it briefly spreading out from the center of the screen, but then just disappears again, going back to the desktop. I can right-click and close the 'PC Settings' application, but that's about it.

In the past when I've had to reactivate other systems (several times), I'm at least able to get to the activation window, even if I have to choose the telephone activation to get it to work (done that before too). I can't even get to the page to select between online and telephone activation.

Has anyone else experienced this and been able to get things back working again, or does anyone have any ideas how to get it back up without calling Microsoft Tech Support (that's the second-to-last resort, of course).

FYI: Yes, it's a legit Windows 8 license purchased at a reputable internet retailer, and it's been working for about a year, and I haven't reactivated this license before. My internet connection is working fine (I'm typing this on the affected system). slmgr/dli tells me 'Name' is 'Windows(R), Professional edition', 'Description' is 'Windows(R) Operating System, RETAIL channel', 'Partial Product Key' is '2KBCY', 'License Status' is 'Notification' and 'Notification Reason' is '0xC004F00F'.

Please note that the 'Windows Store' application and all Metro applications also exhibit the same behavior. In my case, that's not terrible, but I'm researching how to fix this as well and will post back here if I find a solution.

I've tried wsreset.exe as well as sfc /scannow to no avail.

The 'Modern UI App Troubleshooter' fails to repair the problem and reports (after some digging), the following issues:

Checking for HKEY_CURRENT_USER\Software\Classes\Local Settings
(A;;KR;;;AC)(A;OICIID;KR;;;AC) is not the correct setting. Resetting to (A;;KR;;;AC)
Reset result: FAIL 

Checking for HKEY_CURRENT_USER\Software\Classes\Local Settings\MuiCache
(A;OICI;KR;;;AC)(A;OICIID;KR;;;AC) is not the correct setting. Resetting to (A;OICI;KR;;;AC)
Reset result: FAIL 

Checking for HKEY_CURRENT_USER\Software\Classes\Local Settings\Software
(A;;KR;;;AC)(A;OICIID;KR;;;AC) is not the correct setting. Resetting to (A;;KR;;;AC)
Reset result: FAIL 

Checking for HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft
(A;;KR;;;AC)(A;OICIID;KR;;;AC) is not the correct setting. Resetting to (A;;KR;;;AC)
Reset result: FAIL 

Checking for HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows
(A;OICI;KR;;;AC)(A;OICIID;KR;;;AC) is not the correct setting. Resetting to (A;OICI;KR;;;AC)
Reset result: FAIL 
  • It's because you changed motherboards. You have to call. – Jason Dec 3 '14 at 3:33
  • I was referring to calling tech support, not the activation line. I can't get to the page to do telephone activation. Even changing motherboards, you're supposed to be able to reactivate without tech support. I'll clarify that. – James Dec 3 '14 at 4:04
  • Your ability to activate without calling depends on how many times you activated in the past. Sounds like you should just use the phone method and be done with it, you won't be able to activate the license, without calling. There is an option to talk to an actual human when you call they might be able to guide you to a solution. – Ramhound Dec 3 '14 at 4:13
  • @Ramhound, I can't activate by calling--I can't get to that page. My previous reactivation attempts were on other systems. – James Dec 3 '14 at 4:20
  • 1
    Running slui.exe 4 should open the dialog. – magicandre1981 Dec 3 '14 at 17:01
3

For future reference, although the comments above fix the Windows activation issue, if there are also issues opening 'PC Settings' and 'Windows Store', I found the following post that lets me into the 'PC Settings' and the activation dialogs as well (still no Windows Store), and which I believe would have solved the original issue as well: I can't open any Windows 8 apps including PC Settings and Store. In case this post gets deleted, or you don't want to bother reading the conversation there, here is the solution:

Open an administrative command prompt and copy and paste the following (use right-click/Paste to paste into a command prompt window):

powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\camera\AppxManifest.xml
powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\FileManager\AppxManifest.xml
powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\ImmersiveControlPanel\AppxManifest.xml

If we add this to the mix:

powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

the Windows Store starts working, but none of the other Metro Apps do.

After trying numerous suggested approaches, including wsreset.exe, sfc /scannow, switching to a Microsoft account and running the 'Modern UI App Troubleshooter' and switching back, a reboot fixed the issue. Unfortunately I can't say which of those things did the trick, but I was able to successfully recover from this situation without a reinstall, system restore, or refresh.

  • Add-AppxPackage : The specified module could not be found. (Exception from HRES ULT: 0x8007007E) At line:1 char:1 + Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\Ap pxM ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~ + CategoryInfo : NotSpecified: (:) [Add-AppxPackage], FileNotFoun dException + FullyQualifiedErrorId : System.IO.FileNotFoundException,Microsoft.Window s.Appx.PackageManager.Commands.AddAppxPackageCommand – pasha.zhukov Feb 25 '16 at 19:00
  • @pasha.zhukov, do you get that on every command or just on one specific command? – James Feb 25 '16 at 21:40
  • I got it on every command from the answer above. – pasha.zhukov Feb 26 '16 at 5:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.