is there a way to type Euro symbol (something like shortcut) when my keyboard doesn't have that symbol ? My keyboard only have $.

Each time I want to type Euro symbol what I do is copy paste from libreoffice Euro symbol. it is fine when writing in libreoffice, but the problem is when writing in simple word processor (like vim, atom, etc) or in the browser, it is time consuming.



My OS is ubuntu and windows (dual boot, sometimes I use windows , sometimes ubuntu) so anything that work for each case or both is fine.

  • 2
    Try "ALT GR" + "E" Dec 3, 2014 at 13:18
  • 2
    alt e works only when system language is set to an european one Jan 21, 2016 at 9:01
  • I cannot answer, low rep. But in MacOS with US layout you can insert € with OPTION+SHIFT+2
    – Punkman
    Feb 16 at 17:36

6 Answers 6


If you are using a full keyboard, you can try this typing

Alt + 0128

Ref: http://www.irongeek.com/alt-numpad-ascii-key-combos-and-chart.html http://homepages.rootsweb.ancestry.com/~george/ansi_ascii_character_chart.html


It will also depend on what keyboard layout you have.

UK keyboard on Windows it's ctrl/alt/ 4 clearly marked on the keyboard itself.

  • Actually that’s the only thing it depends on. As long as the keyboard generates the correct key press events, at least.
    – Daniel B
    Dec 3, 2014 at 14:21
  • mhm - I spent a few minutes fumbling around with alt/grp [whatever] & got nowhere… til I actually looked down at the keyboard & found it written on;) On my Mac it's on alt/2 so it seems to like hopping around.
    – Tetsujin
    Dec 3, 2014 at 14:25
  • If you use a layout different from how your keyboard is labeled, the labels won’t help. ;) Apple engineers where probably watching And Now for Something Completely Different while designing their keyboard layouts. Or maybe they “thought different”. Who knows.
    – Daniel B
    Dec 3, 2014 at 15:17
  • Actually, they 'thought sensible' but then someone added a Euro sign & like everybody else, they had nowhere to put it;) - dollar/pound symbols were already on 3 & 4, for both UK & US… so I guess they just put it next door & relegated something
    – Tetsujin
    Dec 3, 2014 at 16:23

On Windows try ctrl + alt + E or AltGr + E. On keybords where this shortcut is already used (e.g. on Polish Programmers keybord AltGr + E produces 'ę'), use AltGr + U.

If this does not work for you, take a look at How to type the euro sign topic in help for Microsoft Office.

  • 1
    CTRL + ALT + E worked for me, but only in Word, not in notepad, neither in this comment box, not in Excel. Any more tips how to do that?
    – Firee
    Dec 4, 2014 at 5:38
  • For me it works everywhere - Word, Excel, Notepad, command prompt, any application. Seems it is handled by operating system and not individually by apps. In your case maybe you have a shortcut defined in Word? What keyboard layout are you using?
    – MBu
    Dec 4, 2014 at 8:36
  • I am using a laptop.. Lenovo Thinkpad X230...
    – Firee
    Dec 4, 2014 at 13:01
  • @Firee You can check the keyboard layout you use in Control Panel in regional settings. This is how Windows interprets the keystrokes and what the help topic I mentioned refers to. Imagine the same model of laptop sold in different countries where different diacritical characters are used. All the keyboards have the same internal wiring, the only differences are labels on individual keys and the keyboard layout set in Control Panel.
    – MBu
    Dec 4, 2014 at 13:18
  • Ctrl + Alt + E (English layout) or Alt Gr + E (German layout) work both in Word 2016 and Notepad on Windows 10. Oct 21, 2016 at 15:39

It depends on which operating system you have (Windows, Linux, OS X, ..). Maybe you could add that information to the question.

On Windows you could try to memorize Alt+0128 (hold the Alt key, then type the code on the numerical part on the right side of your keyboard). There are also many utilities to help enter special characters, such as AllChars or UniChars.


Well, I realize different OS has different "how to do it", any way :

  • in windows (thanks @Berend and @Charm_quark) press and hold Alt then type 0128
  • in Ubuntu link Ctrl+Shift+u then type 20ac



Irish keyboard Alt GR+4 on Ubuntu possibly UK keyboard as well.

Not the answer you're looking for? Browse other questions tagged or ask your own question.