1

I recently installed Emacs 24.4 through homebrew through the command

brew install emacs --cocoa

I need to edit the files in a remote cluster with two step authentication. To do this I save the login credentials for the remote cluster through ControlMaster in ~/.ssh/config as

Host *
ForwardAgent yes
ControlMaster auto
ControlPath ~/.ssh/%r@%h:%p
ServerAliveCountMax=30
ServerAliveInterval=5

However when I try to edit the remote cluster files through tramp as

/ssh:username@remotecluster:~/filename

the emacs hangs with the message Waiting for prompts from remote shell which shows that tramp is NOT recognizing the ssh config information.

I provided the option

(setq tramp-verbose 500)

in ~/.emacs and I got the following message in the tramp debug buffer which gets repeated over & over.

Error Message:

    14:19:45.324180 tramp-file-name-handler (1) # Suppress received in operation (file-exists-p
    14:19:45.324396 tramp-get-file-property (8) #  file-truename nil
    14:19:45.324550 tramp-flush-directory-property (8) # 
    14:19:45.324713 tramp-get-connection-property (7) # process-name nil
    14:19:45.324897 tramp-flush-connection-property (7) # [ssh username remotecluster nil nil] nil
    14:19:45.325106 tramp-get-connection-property (7) # process-buffer nil
    14:19:45.325306 tramp-get-file-property (8) # / file-truename nil
    14:19:45.325462 tramp-flush-file-property (8) # /
    14:19:45.325863 tramp-get-connection-property (7) # ~ undef
    14:19:45.326046 tramp-get-connection-property (7) # process-name nil
    14:19:45.326224 tramp-get-connection-property (7) # process-name nil
    14:19:45.326376 tramp-get-connection-property (7) # process-buffer nil

Note: Following the same procedure, I do not face any issue using tramp in emacs 24 in Ubuntu 14.04.

0

For further analysis, one would need to investigate the whole debug buffer. Setting tramp-verbose to 500 looks impressive, a value of 10 would suffice already :-)

You could send me the debug buffer directly per email for analysis. Or use the Tramp mailing list.

0

"Waiting for prompts from remote shell"

There are other possibilities here. Your prompt may not match tramp-shell-prompt-pattern Can you post the values of tramp-shell-prompt-pattern and tramp-password-prompt-regexp . I recently added Passcode to mine to use two factor auth.

(setq tramp-password-prompt-regexp
 (concat
  "^.*"
  (regexp-opt
   '("Passphrase" "passphrase"
     "Password" "password"
     "Passcode" "passcode) t)
  ".*:\0? *"))

I'm also curious if you got the Control master to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.