1

I am having this problem where ajax calls to my dev server is not working. The weird thing is that it only happens on this one particular machine.

It happens across all browsers, when I use Chrome debugger to inspect network traffic, it seems like the OPTIONS request was never sent out and says net::ERR_EMPTY_RESPONSE on the console. It behaves the same across all browsers on this computer, but works perfectly on any other computers. When I used CURL or Telnet in my terminal to make the options call, cURL returns

 Jon-MacBook-Air:~ jsmith$ curl -X OPTIONS http://dev.abc.com/dashboardLogin.php
 curl: (52) Empty reply from server

while Telnet returns

 Jon-MacBook-Air:~ jsmith$ telnet dev.abc.com 80 
 Trying 10.10.11.59...
 Connected to dev.abc.com.
 Escape character is '^]'.
 OPTIONS dashboardLogin.php HTTP/1.1
 Connection closed by foreign host.

I tried the same address with GET with both cURL and Telnet, and both worked fine. Let me also reemphasize that this problem only happens on this one computer running OSX Yosemite.

1

I had this issue recently-- exact same behavior where HTTP GET requests were working, HTTPS OPTIONS requests were working, but HTTP (non-secured) OPTIONS were not. I noticed there was a running process called vpnagentd running in the background, even though I was not connected to a VPN. Traced this process to a Cisco AnyConnect driver I had to install for a client project. Once I uninstalled Anyconnect, unsecured HTTP OPTIONS requests started working again. If you have Anyconnect installed, try uninstalling and see if that fixes your issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.