0

All this is on Windows 7 x64 Ultimate and is fully up to date with it's patches. I was running Chrome 37 when it said it wasn't able to upgrade chrome (it didn't give a reason why). So I uninstalled Chrome and reinstalled it from scratch. Now I'm at Chrome 39.

I should also point out that I have changed my Program Files location by manipulating ProgramFilesDir, ProgramFilesDir (x86), and ProgramW6432Dir in the registry at HKLM\Software\Microsoft\Windows\CurrentVersion because I have an SSD and would rather install on my secondary drive. These registry values are changed to D:\Program Files and D:\Program Files (x86) accordingly. I've had these values changed for a couple years and have never had issues with it (except some programs still manage to install to C). If at all possible, I'd like not to change these back to the C drive.

Chrome installs without a hitch and I can find it in C:\Program Files (x86)\Google\Chrome\Application\chrome.exe along with it's accompanying files in the same folder. After installing, it pins itself to the taskbar and runs an instance of the browser. With that instance going, the pinned Chrome icon in the taskbar is highlighted normally just as you'd expect. If I close Chrome and attempt to reopen it by the pinned shortcut, I get this popup:

D:\Program Files(x86)\Google\Chrome\Application\chrome.exe The specified path does not exist.

Semi correctly, there is of course no file there in the D drive. However it shouldn't be looking in D, it should be looking in C where it successfully installed.

I hold shift and right click the shortcut and click properties. The Target of the link is pointing to the D path. I change the D to C, click Apply, click OK, and try to click the link again and I STILL get the popup above! If I go back to the properties, it has reverted back to D instead of changing to C. I remove this taskbar link.

So I tried going to C:\Program Files (x86)\Google\Chrome\Application\chrome.exe and dragging the exe to the taskbar to create a shortcut directly to the exe. This is where things get weird (again). After clicking on the new link, Chrome opens as expected and a SECOND Chrome shortcut will popup on the taskbar:

Two Selected Icons

Then the original link will become unselected after about 3 seconds:

One Selected, One Deselected

Then the original link disappears and the new link gets a default icon after about another 3 seconds:

Single Generic Icon

Closing Chrome and using the new generic icon pinned in the taskbar behaves exactly the same as above where it says it can't find it on the D drive. Again, I can't change it's properties without it changing back.

I've restarted a few times and uninstalled/reinstalled Chrome a dozen or so times by now. I've tried both Google Chrome's Single User installer and it's Multiple User Installer as suggested by a few outdated forum posts. Never am I offered a choice of where to install Chrome (if I could, I'd put it in D so it wouldn't be on my SSD and things would stop complaining).

I'm at my wits end! What's happening here and how can I set up a simple link to Chrome?

0

Since you have installed google chrome in C:/Program files(x86) but regularly getting the alert message while opening the Google chrome.Can you please verify the executable path is correct in the registry.

Open the registry and then transverse to the path

HKEY_CLASSES_ROOT\Wow6432Node\CLSID{5C65F4B0-3651-4514-B207-D10CB699B14B}\LocalServer32.

Here check whether the executable path is C:/Program files(x86).If it is different change the path in the registry.

| improve this answer | |
  • I just checked. The path is the C drive. Both the default value and the ServerExecutable point to C:\Program Files (x86)\Google\Chrome\Application\39.0.2171.71\delegate_server.exe. The only difference between default and ServerExecutable is that default has the path in quotes. I also checked and that file does exist. – Corey Ogburn Dec 4 '14 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.