5

When downloading files from the Internet in browsers such as Chrome it seems that they set a flag of some sort on the file telling Windows that the file was downloaded form the Internet and that it might not be safe.

For a lot of files this does not cause a problem, opening the file happens fairly quickly prompting me to enter admin mode for the install if needed.

It seems however that for programs with less “reputation,” maybe they don’t have a digital cert or maybe they have only just been released, Windows takes a long time to open the file. Sitting there apparently not doing anything for up to 10 minutes before it finally decides to open the file.

Of course in this time I might have tried to open the file more than once, in that case both files execute at the same time once Windows decides it has checked whatever it needs to check.

I notice that for these files even opening the properties of the file in Windows explorer is very slow, taking the same amount of time. When the file properties do finally open I see an 'Unblock' option in there. I believe this is the flag causing the problem.

Does anybody know what is causing this and how to stop it? It is very annoying. I don’t really know what is responsible for it, maybe Windows Defender?

This happens on all my Windows machines including a fresh install of Windows 8.1 that was installed yesterday. The only antivirus running on the machine is Windows Defender that came with Windows 8.1. There are no other security, adware or malware programs installed.

An interesting note is that if I use a download manager to download the file it seems that this flag is not set on the file and the files always open straight away.

UPDATE1 (include comments summary):

Browsers Affected:

  1. Chrome: Very slow to open properties / execute file after download

  2. Internet Explorer. After download runs 'security scan' which takes maybe 10 seconds then opens instantly both in IE and Explorer

Anti-Virus:

  1. Windows Defender
  2. MalwareBytes (on one machine but not another that is also affected)
  3. Download Managers (such as Download Ninja), files open straight away, no delay

Possible Causes / Solutions:

Disable Windows Defender:

  • This does not seem to have any effect on the time required to open a file

Caused by large file size?:

  • The files I am testing this with are only about 5-6mb so I am not sure this is the case

Happens with all files?:

  • If it download a well known file such as putty it opens straight away

Enable 'Do not preserve zone information in file attachments' in Policy Editor:

  • This stops the 'Unblock' button from being shown in properties but it does not appear to speed up the opening of the file. In my tests after setting this option files still take ~30s-4m to open after download
  • Does this happen with Firefox or Internet Explorer ( with the same file ) – Ramhound Dec 4 '14 at 11:56
  • I just downloaded the same file in IE and it ran a security scan after the download. That took about 20 seconds and after that the file ran quickly. That might be because of the security scan resetting the 'Unblock' flag or maybe because I had already downloaded it earlier? – ant-fx Dec 4 '14 at 12:01
  • What is your installed security suite or antivirus? – harrymc Mar 5 '15 at 8:58
  • Windows Defender + Malware Bytes but I have this problem on machines that only have Windows Defender installed. Perhaps something to do with my location? Internet speed is OK however (12mb/1mb) – ant-fx Mar 5 '15 at 9:33
  • It seems that the problem only happens on files that are marked as unsafe because coming from the Internet. What happens if your disable Windows Defender? – harrymc Mar 5 '15 at 13:31
3

Windows 8.x has the "Windows Smartscreen" universally on the operating system (previously this "filter" was a feature of Internet Explorer only), which means it scans files from the internet against their servers. Maybe you should try and disable that feature and see if it helps?

Go to Action Center (Notification Bar> Flag icon, or Control Panel > Action Center) and from there, in the vertical menubar to the left, choose "Change Windows Smartscreen Settings" Choose "Don't do anything (Turn of Smartscreen)"

If this doesn't help it is highly recommended that you turn this back on!

EDIT: This could also be true for many other antivirus software that has real time protection.

2

Give this a shot.
First open group policy editor (gpedit.msc)
Browse to User Configuration -> Administrative Templates -> Windows Components -> Attachment Manager
Set "Do not preserve zone information in file attachments" to Enable.
Now go into chrome settings -> Show advanced settings
Scroll to the download section and select "ask where to save each file before downloading"
Close and relaunch chrome, download your file again and see what happens.
This should get rid of that pesky Unlock button in properties.

You may need to do a restart or run "gpupdate /force" from elevated cmd to get the policy to take effect.

  • Chrome uses its own method to verify the reputation of a file. This will only prevent Windows itself from having a problem with a file when it can't confirm its reputation. This feature only exists on versions of Windows 8.0 and beyond. – Ramhound Mar 5 '15 at 16:56
  • User posted in comments above that once he hits unblock button, the file behaves more normally. Solution stops chrome from setting this. – Cosco Tech Mar 5 '15 at 17:03
  • There are far to many comments for me to follow. The question should be updated to reflect that fact. My comment is an overall statement. – Ramhound Mar 5 '15 at 17:21
  • Interesting.. the Unlock button goes away after downloading and opening the file properties but it still takes a long time to open the file properties. – ant-fx Mar 6 '15 at 7:41
  • @user1167223 ok, are you willing to allow me to download the file and see if I can recreate the situation. – Cosco Tech Mar 6 '15 at 20:54
0

A selective slow-down that happens only on the first usage of the file is just too weird, so I think that it must be caused by some installed software product.

This can be checked by booting into Safe mode to see if the slow-down disappears.

If it does, then for example Autoruns for Windows can be used to see all startups and turn them easily off/on until the culprit is found.

0

Try to uninstall Microsoft Anti-Virus. My experience is that after I installed 3rd party AV (Avira Free), then the check time was shorten.

0

I think chrome is setting a flag on file as you said can be removed from "Chrome Settings" by removing the tick mark on:
"Enable phishing and malware protection".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.