0

For a couple of days, my router (ZyXEL ZyWALL USG 20W) handles wrong IP addresses to several LAN devices. Where all my devices formerly got addresses in 192.168.1.*, they now get 192.168.2.* upon connection.

This happens even if their MAC address is bound in the router to a static IP of the form 192.168.1.*.

Only one Ethernet port of the router is physically connected, P2. The port's role is lan1 (LAN1): enter image description here

and the adress for it is 192.168.1.1 (it's also the address I use to login on the router): enter image description here

I have the units' MAC addresses bound to static IP addresses outside the range reserved for the DHCP server. enter image description here enter image description here

It looks as if some other unit on the network was running its own DHCP and giving away 192.168.2.* addresses. Is there a way to check who handle a unit its IP?

Any other suggestion as to why I suddenly get 192.168.2.*?

  • You can always use Wireshark to capture DHCP traffic. It works best if you’re the one requesting a new address, though. Try ipconfig /renew if on Windows. – Daniel B Dec 5 '14 at 12:02
  • 1
    Please run ipconfig /all and check (/post here) the values for IP address, netmask, gateway, DHCP server and DNS servers. – Werner Henze Dec 5 '14 at 12:34
  • I am on linux. I ran a factory reset of the router, which solved the problem. No one had logged in on the router around the time what the fault started to appear, I'm tempted to blame the router's (lack of) robustness. – Gauthier Dec 5 '14 at 13:26
  • @Gauthier If a factory reset "fixed it", then you should add that as an answer; Or just delete your question if you don't feel it's needed anymore. :) – Ƭᴇcʜιᴇ007 Dec 5 '14 at 19:11
0

Fixed with a hardware factory reset, and reentering the MAC/IP bindings by hand.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.