0

Yes, this question has been asked before, but as far as I'm concerned it has not been answered satisfactorily. Many answers mention that an extra line in /etc/fstab is required. I don't want to add such a line, because I have several USB drives - which I guess will all need their own line with their own label. It will mess up my /etc/fstab file. FYI: I normally put in only one USB drive at a time. I've tried using chmod, chown but to no avail. I've tried the Gnome disk utility but I don't see how it will allow me to change permissions. I've tried to use pmount. So far the other users on my machine continue getting "permission denied". Why does this seem to be so difficult?

0

Maybe you could try passing in umask parameters when mounting?

# sudo mount /dev/sda1 /mnt/usb -o umask=000

chmod/chown wont work because permissions are already determined at time of mount. Most drives are also formatted with FAT32 thus are unable to store UNIX permissions

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.