3

I have a HP Pavilion computer running Windows 8.1, and the other day it stopped connecting to the internet, although it would still list WiFi routers. I tried three sources, and none worked, although it would say it connected. I ran the troubleshooting wizard, I restarted the WiFi hardware, and I checked the command prompt "ipconfig" with /release and /renew, but nothing worked.

In fact, it gets weirder after checking "ipconfig". It would return a blank, basically.

c:users/moi>ipconfig
Windows IP Configuration
c:users/moi>ipconfig /release
This operation failed as no adapter is in the state permissible for this operation.
c:users/moi>ipconfig /help
[Help was the only working command.]

I don't know what that means, but after trying it on a working one, I think something weird's going on... I do know it's a software problem though. I played with a Linux Liveboot running Lubuntu or whatever it's called, and it worked perfectly.

  • It seems like the driver got somehow broken. Go to device manager>network adapters and list what you have there. – Logern Dec 7 '14 at 2:20
  • Network adapters... Realteck PCIe FE Family Controller or Realtek RTL8188EE 802.11BGN Wi-Fi Adapter? Both have options for update and rollback driver. (Huh, no multiline comments?) – Vector Lightning Dec 7 '14 at 2:24
  • I give up at this and can't test anything. My dad had someone factory reset it after backing up. I should've mentioned this a long time ago sorry. – Vector Lightning Oct 31 '15 at 18:59
3

I had the exact issue yesterday with a laptop: the wireless network adapter was an Intel N1-100 and the OS was Windows 10 pre-testing image.

What didn't work

  • I tried to uninstall the drivers and then reinstall them
  • Tried netsh winsock reset catalog
  • Tried to set and static ip
  • Tried ping 127.0.0.1 and was successful

What did work

  1. Checked the ipconfig /all info and confirmed there was some additional information and routing was not enabled
  2. Checked each feature on my wireless adapter in adapter settings.
  3. Confirmed there was a feature that has the name of my antivirus (AVG). I don't remember the feature name but it has the keyword "avg" on it.
  4. Tried disabling the antivirus but the feature was still enabled on the adapter.
  5. Disabled this feature.

After that, ipconfig begin to work, showing the whole information again successfully. I don't know why the antivirus affected the whole adapter configuration.

  • Please post a question instead - thanks. – suspectus Jul 17 '15 at 18:18
  • Sorry if I'm reviving an old thread, but I just updated my laptop and desktop to Windows 10 and the same problem occurred. Opening adapter settings and disabling one for Comodo fixed the issue. Now I'm connected. P.S. there is a good reason why I have Ubuntu as my primary OS :) – nurchi Dec 15 '15 at 22:28
1

This is mostly happens on the machines which are set to use a static/fixed IP. Please try the below steps"

Open CMD prompt using "Run as Administrator" option

Type the command netsh winsock reset catalog and press ENTER

Then type netsh int ip reset reset.log and press ENTER

Now restart your system

Once the machine is up then try the commands ipconfig /release and ipconfig /renew

  • Okay... Nope no noticeable change. What exactly did I do anyway? – Vector Lightning Dec 7 '14 at 21:04
0

I was having trouble connecting to a certain Wifi network at a coffee shop and ipconfig /reset didn't do anything because I wasn't connected to the internet. I have Windows 7.

The first thing I tried was asking them to reset the router, and I reset my computer, but I still could not get on.

What ended up working was updating the device driver.

Go to Update Drivers -> Network Adapaters -> Microsoft Virtual Wifi Miniport Adapter Right click to get to Properties, and update the driver. Then restart computer.

Once I followed these steps, I was able to connect to the Wifi network that I couldn't connect to previously.

That might work.

0

If it is an external WiFi adapter, try disconnecting it and reconnecting it. My WiFi adapter seems to go on vacation sometimes. This usually works. If its a USB one then try plugging it into a different USB port. If its an internal one the, you could try moving it to a different PCIe slot? Try an external WiFi adapter and see if that works.

0

I've been having the same issue with my killer e2200 Gigabit Ethernet Controller after a windows 10 update overnight. My motherboard has 2 ethernet ports and I'm using them bridged to provide LAN connection to my other computer beside it, so the 2 computers have internet access.

So after the windows 10 update, my network connection was "limited" and I couldn't access internet on the first computer that bridges the LAN, but I was having internet on the second computer (Really, really confusing). After a bit of struggle, I discovered that the problem was the "Killer Bandwidth Control" option that was checked in the adapter properties. Just try to un-check that if you happen to have the same problem as I did.

Hope this can help someone !

solution

protected by Community Feb 27 '17 at 2:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.