I use Thunderbird 3 with my GMail account using IMAP. When I send messages via Thunderbird to Google Groups I am subscribed to, my own messages do no appear in threads. Looking at the same threads in the GMail UI and the Groups UI, my own messages show up just fine.

Is there a way to get my own messages to show up in Thunderbird?

2 Answers 2


Gmail de-duplicates emails. When you send a mail, the copy which comes back in is found to match the copy you already have and ignored. This is why mail you send from your own address often just appears in Sent Mail.

Sent Mail is still in the conversation, and should still have the References: headers to allow it to be threaded.

I suspect that you're using Gmail filters to tag mails based on the list as they come in? So this works in Gmail because when you look at a label in Gmail, you select conversations (threads) rather than messages, so you get all the replies. The mail you sent won't itself have the label though, so on a strictly message-based interface such as IMAP that mail won't appear in the folder.

If you're using listid: to filter mail in Gmail, try using list: instead. The list: operator handles the To: header, as well as List-Id:, so is better than the listid: operator (which is just too low-level). Use <...> around the list-id to change the tokenisation to be more appropriate (and the '@' is a magic @ here, which will match the '.' form in the List-Id: header).

  • Thanks for the comprehensive answer, that makes sense. However, I have just checked and the filter I am using in Gmail is already using list: Any other suggestions on how to make this work? Dec 18, 2009 at 15:05

I have just solved this problem using the Send Filter add-on for Thunderbird.

Note, a TB3 compatible version is available.

Send filtering is also supposedly going to be available natively in TB3, but as of the 3.0 release, I can't see that it's in there.

With this add-on installed I am simply creating filters on the To: field for the relevant lists and setting the action to copy the message to the relevant folder. Works just fine.

  • I have this same problem but I don't understand how the Send Filter add-on solves the problem.
    – James Ward
    Jul 6, 2011 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.