10

I found out that at windows folder search the letter dash "-" works as eliminating the following word from search results.

However i have files that contains dash "-"

So how can i filter them ?

For example i have image named as

"my-home"

But when i type as below nothing appears

Windows 8.1

At here it tells the following

Here’s a list of AQS operators that have to do with text searching:

NOT/- : Both “not” as well as prefixing a dash will tell your search to exclude items that include the following term.
AND/+ : Both “and” as well as prefixing a plus sign will force your search to only include items that match for both terms.
“” : Using quotes will force a search to filter for an exact phrase.

enter image description here

9

How can I find files in Windows Explorer where the name contains -?

The following search expression will match all files that contain a - character:

~*-*

Explanation:

  • ~ literal match

  • * wildcard match

  • - match the -

  • * wildcard match

So ~*-* will match all filenames with any characters before a literal - and any characters after a literal -

You can also " the search expression, so

"*-*"

will also work.

| improve this answer | |
  • 2
    Is there a reference for how to properly use the windows search box? My god, it drives me absolutely BONKERS trying to figure it out. – Wayne Uroda Jun 1 '17 at 4:27
  • @WayneUroda Read the series starting with Lesson 1: Stop Hunting and Start Finding! – DavidPostill Jun 1 '17 at 8:25
  • Better link directly to the article: docs.microsoft.com/en-us/windows/desktop/lwef/… – Chad Aug 9 '18 at 5:52
  • I wanted to find all files that I had made a copy of. So windows will suffix those with a "- Copy" before the extension. I found that I needed to use the ~ and the quotes to make this work. And I also made sure it only focused on the name. So, this worked for me... name:~"- Copy" – AmoebaMan17 Oct 22 '19 at 16:27
  • Trying to " the search expression has no effect at all, while adding ~ at the beginning does the trick, thanks a lot! – RAM237 Apr 10 at 9:27
3

I had a similar problem with a file named hello-world. So if I tried searching only the word hello the file could be found. If I tried searching the word world the file is not found. In my search I did not use the -. However there seems to be some problem if the filename contains a -.

After trying to change indexing options and other complicated stuff the best solution I found was to search with a *.

So for example the search term *world finds my file. For now on I will be searching only with the *.

| improve this answer | |
0

I have had similar issues. At work I have file names such as snstore-surv-nyc-10-mobile.

What works is using the * character to expand the search

Example:

snstore*nyc or 
snstore*mobile

Unfortunately I haven't found a way of expanding the search to three variables

snstore*nyc*mobile
| improve this answer | |
0

Its work for me,

I have a lot of file using dash, i.e: ff-0101-12345, ff-0102-12345, ff-0000-12356

When i tried type in the search bar only 123, that will show nothing in the search result. It work fine when i type * before word that i will looking for. Like *123 so it will show search result that match --> ff-0101-12345, ff-0102-12345, ff-0000-12356

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.