9

I have been facing this problem from times immemorial. Whenever I copy a table with data, either numbers or text, from Excel to Powerpoint, most of the time I get numerous spaces before the data, which never existed in the Excel file.

It takes a lot of time to get rid of them. I follow some of these, with mixed success:

  1. Using the replace function, but mostly it gets rids of all the spaces among other text also

  2. Manually deleted each space

  3. Trying to keep the numbers in simple Number format, eliminates space before numbers, but this does not solve the spaces before text issues

I've faced this with Office 2007, 2010, and 2013.

1

16 Answers 16

4

This is not a bug in Excel or PowerPoint, I think I was able to figure out the reason for it and the solution was not far off.

What I think is happening is the date/text/negative/positive formatting that you are using in Excel is causing this.

For example, in the tables I was using, I wanted:

  1. Negative numbers as : (52.3) instead of -52.324
  2. Positive numbers as : 23.7 instead of 23.687
  3. And Zero as : - instead of 0.0

Thus when going into the 'custom' Category in 'More Number Formats' dialogue box, the format was showing as:

_(* #,##0_);_(* (#,##0);_(* "-"??_);_(@_)

So when pasting the number into PowerPoint, I guess it was saving all the character spaces, so I read on the custom formats at Microsoft's Create or delete a custom number format, which I suggest you should too, in case you want to be creating your own custom formats.

And then I replaced that horrible looking text with:

*0.0;(0.0);-*

And voila!

Hope this helps anybody who still faces this issue. :)

1

Try creating a blank table in powerpoint and then copy paste the contents from Excel.

0
1

Yes, this problem has been around a while. Perhaps the ideal solution is to have Microsoft recognize the problem and have it fixed from their end.

Making Microsoft listen and recognize it is another problem though. I would suggest providing feedback at every opportunity, and if you have support, raise the issue. MS have email/support contacts so probably possible to raise that way.

A possible work-around, while we wait for the ideal fix, is:

  1. In Excel replace space with some other seldom used temp character (example ~, |, or ^)
  2. Copy data from excel into other app (can be Powerpoint, Word, etc).
  3. From other app, select the pasted table, then do replace-all of spaces with nothing
  4. From other app, while the pasted table is still selected, do replace-all of temp character used in step 1 with space
1

I've found that this happens when my excel cells have some kind of "Custom" format (or even by clicking the "comma style" button). To fix, I change the excel cell formatting back to "Number" format before pasting in powerpoint. This prevents all the annoying spaces from being copied into powerpoint.

Good luck.

0

What I did is to create another sheet within the workbook, and merge the cells with the ampersand (&) symbol.

And make a reference to the cells you want to copy without spaces.


Example

The original sheet1 has in 4 cells the following data.

CELL.A1 CELL.B1 CELL.C1 CELL.D1

Put the following formula in the new Sheet. With the Ampersand you can merge cells. (thats the trick)

=sheet1!A1&sheet1!B1&sheet1!C1&sheet1!D1

the result will be

CELL.A1CELL.A2CELL.A3CELL.A4

without spaces.

1
  • Welcome to Super User. Please be aware you have posted an answer to a question that is very old. Although there is nothing wrong with doing so, just be aware you may not get a response.
    – CharlieRB
    Apr 8 '16 at 17:36
0

One work-around for this one is using "CONCATENATE"

e.g.

=CONCATENATE(A1:H1)

It will combine all the values within the specified tables without spaces.

1
0

Please save as your excel as test.csv document , if you have notepad++ , open test.csv with notepad++. Follow the steps http://bit.ly/2aPgLMn to remove the spaces. Then copy fixed text which platform you want it.

Notepad++ Download

enter image description here

0

Here is a quick workaround... Before you copy the table/data from Excel, make all the cells left justified/aligned. This will avoid spaces inserted at the front when you paste the data in PowerPoint or Outlook. After you finish copy-and-paste, go back to Excel and use "Undo" to restore back to the initial text align setting.

0
0

My quick and dirty solution is to paste the table into outlook, highlight the numbers. format them "Centred" then format them right justified. Then copy the tble from Outlook to Powerpoint and it is done. (Microsoft - you should fix this - it is a pain in the butt!) Michael

1
  • Why Outlook? Outlook does not even come with all editions of Microsoft Office.
    – user477799
    Feb 13 '17 at 7:54
0

I have found what I think is THE solution, Just reduce excel's columns size to fit the content, or just make them real small. This will allow you to copy to powerpoint without any blank spaces.

0

I just discovered that if you first copy from Excel to a MS Word table, then you can copy over to PowerPoint without there being any extra spaces added.

0

I encountered same issue while pasting data from outlook to Excel. I just changed the format in source excel sheet from custom to General with zero decimals and copied and pasted to outlook email. then while copy and pasting from outlook to excel data was spaces free and OK.

0

I found the solution at last! It's quite simple:

  1. Copy the table from Excel into PowerPoint (there will be a bunch of spaces)
  2. Copy the table you just pasted in PowerPoint back into a blank Excel sheet (spaces should be gone now, make sure the Cell type is set to "General")
  3. Copy the table you just pasted in Excel back into PowerPoint

Voila! All the spaces should be gone. (Microsoft should really fix this though...terribly annoying)

0

You can Copy the table in MS-Word, then press ctrl H, enter a space in find, leave other blank, the press replace all, this will replace all the spaces in the table. then paste it in PowerPoint and format it.

Normal Space: Press Space bar (in find) Hard space: Press Alt 0160 (in find)

-1

In my experience, the easiest fix is to change the number format from Accounting to Currency.

Accounting lines up the symbols and decimals for easy reading, while Currency places the symbol next to the amount.

  1. Right click the cell(s).
  2. Click Currency in the left list.
  3. Click OK.
-3

I found a solution:

  1. Select target cells.
  2. Press Ctrl+h for replace command.
  3. Enter a space in find field and leave replace field empty.
  4. Click on replace all. This will remove some of spaces from target cells.
  5. Then u have to DoubleClick a target cell and copy a space.
  6. Then again press Ctrl+h for replace command and paste the copied space in find field and leave replace field empty.
  7. Click on replace all. This will remove all of spaces from target cells.
  8. Done.
2
  • As for "Then u have to DoubleClick a target cell and copy a space" it seems to me you have different types of spaces in your Excel data that you wanted to remove. However, the question is about Excel data without any spaces, for which spaces magically appear after pasting in PowerPoint.
    – Arjan
    Mar 5 '16 at 13:47
  • Please read my question, this method is already tried
    – Firee
    Mar 7 '16 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.