0

I've setup an AWS server, and I can ssh into it from my home computer and everything acts normally. On the server, I can ping to any external website (i.e. google, cnn, reddit), but I can't ping my own computer. This means that I can't scp a file over to my home computer. Given that I have rather large files on the server that I'd like to deal with in a GUI, this has become something of a problem. I have Time Warner cable internet service, which I think might be blocking the pings, but I'm not sure. I also have Ubuntu 14.04. Is there a solution to this problem?

  • We need more information about your home network in order to conclude its only your ISP that is blocking the pings. – Ramhound Dec 7 '14 at 17:26
  • Please provide us some more info on your betwork configuration: router brand/model, ip settings, netmask, ... What OS's do you use? Can you do a traceroute to your computer from the server? Did you try scp even while ping doesn't work? Do you use hostnames or ip addresses? What have you tried yourself? – agtoever Dec 7 '14 at 17:29
1

but I can't ping my own computer. This means that I can't scp a file over to my home computer

Not necessarily. The ability to ping your computer neither confirms nor denies the ability to connect via any other protocol. I wouldn't expect you to be able to ping your home computer from an external host.

If your computer initiates the SCP file transfer then I would expect it to work, just as it does with any other protocol (HTTP, SMTP, etc.) when your computer initiates the communication, unless TWC explicitly blocks SCP traffic. Have you tried it?

If you mean that the server will initiate the SCP transfer then you'll need to allow the appropriate port(s) inbound to your home computer in your home firewall.

0

Your problem might have several reasons:

  • A firewall is blocking pings to your PC, this might be the router or a software firewall on your PC
  • Your provider is blocking pings to your address
  • You probably use an wrong address and not the IP your provider has assigned to you, maybe your local IP address (an IP in your LAN which usally starts with 192.168., 10. or 172.[16-31]. You might check your assigned IP on pages like http://whatsmyip.net/)

I've no exact information about your local network, which would be helpful in order to find the problem I can offer you another solution: scp works in both directions, you can send and also retrieve a file from your server.

In order to send a file/folder to your server you are using:

scp /path/to/SourceFile user@host:/path/to/TargetFile
scp -r /path/to/SourceFolder user@host:/path/to/TargetFolder

and if you want to retrieve a file you can use:

scp user@host:/path/to/SourceFile /path/to/TargetFile
scp -r user@host:/path/to/SourceFolder /path/to/TargetFolder

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.