3

I am able to run a Windows 7 VM at full native resolution on a iMac with a Retina 5K display (HiDPI / Retina, at 5120 x 2880) using VMware Fusion 7.

Windows 8.1, though, does not list any resolution greater than 2560 x 1920. This happens despite having selected the "Use full resolution for Retina display" option in VMware Fusion 7. I have also reinstalled the VMware tools multiple times (that seemed to help in an unrelated Windows XP resolution issue) and tweaked the VMX configuration values -- I even tried to match the values to those found in the Windows 7 VM's VMX. Nothing has worked.

For all I know, VMware may be supporting the native resolution, and it just doesn't show in the Windows 8 "Screen Resolution"'s list of resolutions. I did not find a way to override the list of available resolutions in Windows 8, so I was unable to test that hypothesis.

Has anyone managed to run a Windows 8(.1) VM at 5120 x 2880? In VMware Fusion 7? Any ideas on how to solve this?

  • How do you get the full resolution? 2560x1920 is the highest I see available, even though I have 'Use full resolution for Retina display' enabled (it was the default setting). This with Windows 7 x64 running inside VMWare Fusion 7.1.1. – Ed Avis Mar 1 '15 at 21:37
  • Ed Avis: As far as I remember I didn't do anything special. Do you have the "Scaled high resolution" setting in VMware set to "All View Modes"? I also have 3D graphics enabled, with 256 MB of graphics memory, although that should not matter. Check that you have the VMware tools properly installed, all the OS updates, etc. Report back here for other users. – Luís Marques Mar 2 '15 at 1:27
  • I changed Scaled high resolution to All View Modes, rebooted the VM, but still no higher resolution available. This is VMWware Fusion 7.1.1 downloaded and installed yesterday, OS X 10.10.2 last updated 2015-01-31 (no newer updates are available AFAIK). Windows 7 x64 SP1 installed from DVD. – Ed Avis Mar 2 '15 at 7:03
4

it's a bug and you cannot get a better resolution. I'm stuck with the same issue and it sucks big time if you need your gear for productive office work and need realiability ... VMWare admitted to it Jan 5th (right here - https://communities.vmware.com/thread/497993 ), but hasn't put forth a solution yet. Way to go, VMWare ... maybe it's gonna be a special feature for the next - paid - upgrade version.

  • Thanks. Hopefully they will include the fix for this with the next minor update. – Luís Marques Feb 7 '15 at 16:49
1

I am pleased to announce that I can now get the full 5120 x 2880 resolution on Windows 8.1. I have the R9 295X graphics card option.

How did I do it? I tried all sorts of things. The latest AMD Catalyst drivers didn't work, 14.X 15.X. I tried installing them manually blah blah blah. I tried the Radeon Crimson drivers.

So essentially I just gave up, especially when the CCC Catalyst Control Centre stopped working entirely and I couldn't get the old one back. I thought I better quit while I was ahead.

And then I was working on something else today and a message popped up about updating bootcamp. Somewhat hesitant, I clicked 'okay'.

I didn't think too much about it, and carried on with my work.

Then the screen started flickering by itself and I thought "oh no, it's going to crash".

Then it completely blacked out (twice) and I couldn't do anything and I thought "great I just lost all the work since my last save".

And then when it came back, everything looked TINY.

I checked and low-and-behold, the resolution automatically went from 3840 x 2160 all the way up to 5120 x 2880. And I have to say, yes I can notice the difference.

For starters, webpages look ridiculously small, but this is definitely going to improve my work flow.

There is also the option for 4096 x 2034 pixels.

enter image description here
(Click image to enlarge)

  • Thanks for sharing, Leslie. Don't forget that you can change the screen elements' sizes (although in Windows that doesn't work perfectly, for instance in the login screen it used to not work), by using the "Make text and other items larger or smaller", so that you can have a crisp and yet have things with a sensible size. – Luís Marques Dec 11 '15 at 16:56
  • Leslie Dean Brown: is this a bootcamp partition converted to a VMware virtual machine? A native bootcamp boot? The bootcamp drivers don't seem to allow installation under VMware; on the other hand, this was a question regarding VMware VMs. – Luís Marques Dec 12 '15 at 1:26
0

According to the VMware Knowledge Base for Retina display support:

iMac 5K 5120 x 2880 retina display is currently not supported in VMware Fusion.

Hopefully they add support soon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.