3

VMWare Workstation keeps displaying me the error "\.\Global\vmx86: The system cannot find the file specified." when I try to start a VM. I am using Workstation on a computer with multiple users. Directly after installing Workstation it runs the VM just fine, but after switching users a few times (each of the users also uses the same installation of Worksation with the same VM) it displays this error, followed by "Internal error". The host system is Windows 7 Enterprise 64Bit.

What I have found out so far: - the registry entries HKEY_LOCAL_MACHINE -> SYSTEM -> CURRENT_CONTROL_SET -> ENUM -> ROOT -> LEGACY_VMX86 and HKEY_LOCAL_MACHINE -> SYSTEM -> CURRENT_CONTROL_SET -> services -> vmx86 get deleted at some point

  • in C:\Windows\System32\drivers, the file vmx86.sys gets deleted

  • when I run lusrmgr.msc, the formerly present entry Groups -> vmware is gone

What I have tried: - reinstalling Workstation - helps, but is too time consuming and the problem will occur again soon

  • Running Workstation as admin -> doesn't help

  • renaming vmware.exe (found this tip on the internet) -> no change

  • adding all users who log on to this computer and use the VM in lusrmgr.msc -> Groups -> vmware directly after installation -> seemed to work a bit longer than before, but problem still persists

I am not completely positive that this problem is directly related to switching users, but it only happened after logging out and back in so far. Any help would be much appreciated.

  • What do the vmware people say? BTW VMWare Workstation current release is 11.0. – mdpc Dec 8 '14 at 9:24
  • Haven't asked at the VMware community yet, but will do that right now. But I googled a lot and summarized the suggested work arounds above. Mostly the problem is solved after reinstalling workstation, but not for me. I know Workstation 10 is not the current release but at the moment I have to use it. – dudenr33 Dec 8 '14 at 10:53
  • It seems that this is a problem specific to the pc I'm using. I installed worksation on another computer with (at least almost) identical specs and operation system and the registry entries etc. are still there after multiple switches of users and reboots. – dudenr33 Dec 8 '14 at 12:18
3

I tried @Andreas's solution but running the command didnt seem to result in anything, and I wasn't able to start my vm still.

In the end my solution was to run net start vmx86 in an administrator cmd prompt.

1

Even though this is not exactly a clean solution, it seems like I found a workaround for this problem. Running the command vnetlib -- install vmx86 in the Workstation directory reinstalls the deleted service and the vm can be powered on again (even without rebooting the host - but that's why I consider it only a quick'n'dirty solution and not a permanent fix). Still, if anybody has got a better solution I would be really thankful.

0

I had the same problem, I tried running vmx86 by cmd but it failed. Finally I found out that the 'VMware Authorization Service' was not running. Starting it from services.msc fixed the problem.

0

My workaround is simple, go to the services and start the VMwareHostD Service then run VMware worksataion as administrator.

After a windows update on my windows 10 Computer I noticed that the service did not start at all.

Cheers

Giochajon

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.