43

I tried to download "ECMConfig.cmake" from repository, but terminal gives me an error: "question's title + The following configuration files were considered but not accepted: ECMConfig.cmake : version is unknowed. I tried to search on Google, but got nothing. I wanted to compile from source "kde frameworks" using this command:

cmake .. -DCMAKE_INSTALL_PREFIX=/home/john/QtProjects/KDEStuff/frameworkintegration/build/ 
         -DCMAKE_BUILD_TYPE=debugfull -DCMAKE_PREFIX_PATH=/home/john/Downloads/

P.S:
"/home/john/Downloads/" - where my *.cmake is.

1
  • Just in case remember it could also happen when not having read access on /usr/share. Jun 3, 2022 at 0:47

2 Answers 2

62

Try to clone, compile and install the extra-cmake-modules KDE project. 

git clone https://invent.kde.org/frameworks/extra-cmake-modules.git 
cd extra-cmake-modules
mkdir build && cd build    
cmake ..
make && sudo make install
5
35

In my case I simply had to install the extra-cmake-modules package.

sudo pacman -S extra-cmake-modules
3
  • 3
    This is the best solution! Jun 4, 2018 at 21:36
  • Worked for me with Fedora 30.
    – erik
    Jan 2, 2020 at 15:24
  • Or sudo apt-get install extra-cmake-modules
    – dmatej
    May 10, 2022 at 11:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.