2

I'm trying to follow these instructions to create a VPN server on my home computer, but I keep getting error 812:

The user MicrosoftAccoun\bwsithspawn00@... connected from 192.168.1.1 but failed an authentication attempt due to the following reason: The connection was prevented because of a policy configured on your RAS/VPN server. Specifically, the authentication method used by the server to verify your username and password may not match the authentication method configured in your connection profile. Please contact the Administrator of the RAS server and notify them of this error.

I found a bunch of things describing this error when connecting via Windows server and RRAS, but nothing about home computers. Does anyone know why this would be occurring in Windows 8 home (on both the server and the client)?

  • 1
    When you enter your credentials on the client try <serverMachineName>\<userName> as your user name. – Ƭᴇcʜιᴇ007 Dec 8 '14 at 17:53
1

Judging by what you suggested your user name was being recognized as (MicrosoftAccoun\bwsithspawn00@...), it appears it's trying to use your Microsoft-linked account credentials, and having trouble figuring out where (which domain) to look those credentials up.

Try specifying the server machine specifically as the domain to check, since it's holding the user account/credentials for the user you are trying to log in as.

ie: <serverMachineName>\<userName>.

That way it'll look to the server computer (<serverMachineName>) for the account <username> to try your supplied credentials against.

1

It seems you are not using a required authentication method that your VPN server is asking for.

  1. Make sure you have forwarded port 1723 from your router to your VPN server
  2. Also make sure you set up any VPN Passthrough functionality on your router so that GRE port 47 can reach your LAN
  3. Open Windows 8 Charms bar and click Settings.
  4. Right click your VPN connection on your client (Win 8?) and click "View connection properties"
  5. Click the Security tab at top of window
  6. Make sure the Type of VPN is set to Point-to-Point Tunneling Protocol (PPTP)`
  7. Select Allow these protocols from the middle of the window
  8. Check Microsoft CHAP Version 2 (MS-CHAP v2)

You should then be able to connect...

P.s. You should also make sure you type the right username and password (including the domain of the remote/VPN server)

  • Thanks! in #3, where do I go to right click? – Xodarap Dec 8 '14 at 16:50
  • Updated my answer as, yes, I'd forgotten to show how to get the VPN entries up. – Kinnectus Dec 8 '14 at 17:05
  • tried this but no luck. Do I have to explicitly open a port for step #2 maybe? – Xodarap Dec 8 '14 at 17:45
  • Yes, you do. Very important step to let any traffic into your LAN – Kinnectus Dec 8 '14 at 19:37

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.