2

So, I have a laptop, and a desktop, both Windows 8.1. The laptop follows me wherever I go, and the desktop doesn't. The desktop has 5 external drives, and I am using Storage Spaces to pool the drives together. I have shared the resultant drive (REFS format) on my network, and have mapped to a drive letter on my laptop. So far, so good.

However, when I take the laptop off my home network to, say, the office, whenever I try to open a program that enumerates drives, the system hangs while it tries to connect to the drives. When I open Explorer at the office, it shows the network drive as available, but hangs for a long time, then discovers the network drive is not present.

I have confirmed that this hang is being caused by the mapped drive, because after disconnecting it, the hanging stops and everything goes back to normal.

I have experienced the hanging with the following software:

  • Explorer
  • FileZilla (takes about 2 minutes to open)
  • Skype (when saving a file)
  • Sublime Text 2 (first time a file dialog box is opened)
  • Oxygen XML Editor (any file dialog operation)

Is there anything I can do to either change the timeout when testing a network drives existence, or telling the system to ignore mapped drives unless specifically called?

I have tried working with just shortcuts to the network shares, but with some of the software I use, they don't support explicit network shares (Oxygen XML), and manual intervention would completely undermine the file version history tracker I have set up (would only index bulk commits made during a manual copy, rather than each and every change as I go along).


Additional

I found this issue originally in FileZilla last year at some point, and after raising a case with FileZilla, they came back saying that the hang was being caused by a lower level system component. The only difference between then and now is, then, I was on Windows 8, and the network drive was a single drive instead of storage spaces drive. Sadly, I can't find the case, but there are many others like it.

At that point, I gave up and resigned myself to slow FileZilla startup times, however, the hanging at that time was around 30 seconds, and now it has jumped to 2 minutes, so I really want this problem solved.

  • "network drive was a single drive instead of a single drive" this statement does not make sense in the context of the sentence. – Ramhound Dec 10 '14 at 12:50
  • 2
    Disconnect the drive / remove laptop from network / ... / connect laptop to network / connect the drive? You can probably write a couple of batch files to make this easier ... See NET USE and the /delete option. – DavidPostill Dec 10 '14 at 12:55
  • @Ramhound apologies, edited – topherg Dec 10 '14 at 13:08
  • @DavidPostill let's call that plan b, but I like it. Just have a setup script, a destroy script, and a poller script. When it detects its not there (when not destroyed), run destroy, when it finds it (when not setup), run setup – topherg Dec 10 '14 at 13:09
  • 1
    @cgoddard The answers on that dupe DO stink, they're not really answering the question, so I stuck a 100pt bounty on it myself. ;) – Ƭᴇcʜιᴇ007 Dec 10 '14 at 15:34