2

I'm trying to install Linux from a live CD (Elementary OS)

I set my boot priority order so that CDROM was first in the BIOS.

However my PC always chooses to load my SSD drive instead.

To check that the live CD is working correctly I unplugged all my drives EXCEPT my CDROM drive.

With this configuration the CDROM boots and I'm able to trial Elementary OS.

Upon plugging the SSD back in, the SSD always loads first.

I have checked my BIOS at least 3 times and I am ensuring that CDROM is the first to boot. I have also attempted to load CDROM via the boot selector after post (via f12). Still, it loads the SSD instead. So I KNOW for sure my live CD is bootable and works correctly.

It's bizarre! I know the live CD works and I have triple checked the boot order, but it simply will not load if my SSD is plugged in..

Extra info which may help

On the SSD I already have a dual boot setup with ubuntu and windows 7. I wonder if somehow this could effect the boot order. I don't really know how....

Is there something else I'm missing? can MBR's somehow override BIOS boot order?

My motherboard is a Gigabyte GA-970A-UD3

Updates

  1. I checked my cdrom drive for a master slave jumper on the back. There are no jumpers. This is a SATA drive
  2. I swapped the SATA connectors on the motherboard so that the CDROM is plugged into the first SATA port, still the hard drive loads instead of CDROM
  3. The BIOS version is AMD ACHI version 3.07
  • Is there any jumper settings in your CD-ROM like master/slave?. If so try changing this setting. – vembutech Dec 10 '14 at 13:10
  • No jumpers, see updates in question. – Lucas Scholten Dec 10 '14 at 13:30
  • Try to physically switch the cables (cd and SSD) on the motherboard (I mean unplug the cable from cd and plug it in SSD and vice versa)... BTW which version of BIOS? – Hastur Dec 10 '14 at 13:40
  • @Hastur please see original post. I have already tried to physically swap the cables on the motherboard so that the CDROM is now plugged in where the SSD was plugged in (SATA port 0) – Lucas Scholten Dec 10 '14 at 15:27
  • @Hastur The BIOS version is AMD ACHI 3.07 – Lucas Scholten Dec 10 '14 at 15:31
2

It seems on this particular motherboard its possible to have the first 4 ports running on AHCI mode and the last 2 running on IDE mode.

I had been running everything on AHCI because of the SSD. The CDROM drive was also plugged into an ACHI enabled port which seemed to work fine for everything except in this instance where it refused to boot.

SOLUTION : Plug the CDROM SATA cable into an IDE enabled SATA port and voila, it now boots like it's supposed to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.