11

I just built a brand new computer. I inserted the windows 7 ultimate disk into the drive, and when prompted, pressed a key to boot from the CD. At this point, the computer itself is able to detect the keyboard.

However, once the installation software loads and I'm prompted to select a language, Windows does not detect either the mouse or keyboard. I can't give any input, and therefore can't install the OS.

I've tried multiple USB ports, and 2 different key boards (I only have 1 mouse) and nothing has worked. How do I get it to find the input devices?

EDIT: A bunch of places say the problem is the Windows 7 installer doesn't support USB 3.0, but when I switched to a USB 2 port I still have the same problem.

EDIT 2: per request:

Motherboard: GIGABYTE GA-Z97X-UD5H
Keyboard: Microsoft Sidewinder x4
Mouse: Logitech G600

There's also a standard Microsoft USB keyboard I tried, but I'm not sure the model number.

  • 1
    Awesome thanks for edit 2. Yikes Z97 chipset, in my conservative world that still counts as bleeding edge :-p I am now 100% certain that your issue is related to a BIOS setting. We can assume that Gigabyte expects most folks to be installing Windows 8.x, and has a default out-of-the-box configuration that supports that. Have a play with the BIOS settings yourself along the lines I mentioned, meanwhile I'll do some more research... – misha256 Dec 11 '14 at 18:38
  • I have combed through the user manual for your motherboard and it should work out-of-the-box with Windows 7. I can see no reason why your keyboard/mouse would not be detected during Windows 7 setup. I'm posting another answer... – misha256 Dec 11 '14 at 18:51
  • Non of below advises helped with my Pegatron motherboard. I used another pc to install windows 7 on harddrive. Also I've installed drivers (USB,MBORD), even though they were not for that pc. Then I moved HDD back to Pegatron and it worked. Another trick is to install LAN driver and then use remote desktop to install kb/mouse driver remotely. – stiv Mar 9 '18 at 21:19
8

You haven't given us any details about your PC (motherboard, keyboard, mouse make and model). You can edit your question to include the specs.

Meanwhile I have two solutions you may try. None of them do anything bad to your system.

Solution 1

This may seem counter-intuitive but Windows 7's USB stack is fully operational during setup. It will detect USB device insertions and removals.

Knowing this, you can overcome possible BIOS USB bugs by booting into Windows seutp exactly as you did, wait until the choose language screen appears, then without turning the computer off or rebooting unplug the keyboard and mouse and plug them back into different USB ports. This trick has worked for me in the past.

Solution 2

You may need to adjust some settings in your BIOS. Your motherboard manual will have instructions on how to enter BIOS setup.

When you get into BIOS setup, trawl through all the various menus and sub-menus and try find the following options. They might not read exactly as I've written them but you'll spot them if they're there.

Windows 7 has no need for BIOS legacy support, in fact it can interfere sometimes, so set these options:

  • Legacy USB = Disabled
  • EHCI Pre-Boot Driver = Disabled
  • XHCI Pre-Boot Driver = Disabled

Also make sure USB2 support is enabled, if the option exists:

  • EHCI/USB 2.0 = Enabled

Or if the above option doesn't exist, make sure USB 3.0 is switchable:

  • XHCI/USB 3.0 Switchable = Enabled

Also set these options if you have them, this adjusts how BIOS hands over the USB controller to the OS when it needs it:

  • EHCI/USB 2.0 hand-off = Disabled
  • XHCI/USB 3.0 hand-off = Enabled

Make sure you save the settings before exiting BIOS setup.

As you pointed out yourself do use USB 2.0 ports if you have them. Good luck and let us know how you go :-)

Update: If you are using a newer Intel processor with USB 3.0 you might have to add the USB 3.0 drivers to the installation image. You can do this the hard way using the Windows DSIM utility but Intel also distributes a tool to automate the process. More info is on Intel's website.

  • Updated with specs. I've tried (1), but I assumed that I needed everything in (2) to be enabled or auto, so I'll give that a shot when I get home and follow up. Thanks! – ewok Dec 11 '14 at 15:12
  • In case someone has this issue with a Lenovo ThinkStation P310 (30AT0024GE, Mainboard V1.0), here is how you get it to work: In BIOS, set USB Support to Enabled, USB Legacy Support to Disabled and USB Virtual KBC Support to Enabled. Then, make sure you boot in UEFI mode (Legacy won't work!), which you can do via the boot menu every time you boot or you simply set the BIOS option Boot Priority to UEFI First and all should work fine from here on out. – domsson Jan 31 '17 at 11:27
4

I solved the problem that i had with my MSI motherboard. It had an option that was called windows 7 installation and windows 8 installation. Both were disabled. I enabled the windows 7 installation option and now it recognized both the keyboard and the mouse in usb 3.0 aswell..

  • I also have a MSI board (Z170A PC MATE) and this solution almost worked. I had to disable XHCI Hand-off and Legacy USB Support under Settings/Advanced/Usb Configuration along with enabling Windows 7 installation under Settings/Advanced/Windows OS Configuration in the BIOS. – payling Dec 18 '15 at 3:22
0

Not sure if this will work:
Try not just just switching, but rebooting with the keyboard and mouse already plugged in to 2.0 ports.

It might not recognize new hardware after its booted, or hardware in the 3.0 ports while booting.

  • I did try that. Thanks, though – ewok Dec 11 '14 at 3:49
0

Now that we know your motherboard make/model, things get interesting.

Out-of-the-box your motherboard is configured in a way that should support Windows 7. As long as you plug the keybaord and mouse into the USB 2.0/1.1 ports:

USB 2.0/1.1 Ports

Few more things to try:

  • In BIOS setup, reset all settings to factory defaults, save and exit. Try Win7 setup again. If no luck...

  • Update the BIOS to the latest version. Try Win7 setup again. If no luck...

  • Instead of booting with the Win7 DVD, use a Win8.x DVD and see if the keyboard/mouse works. If the keyboard and mouse still doesn't work even on Windows 8.x setup, then it's likely something dodgy is up with your motherboard.

If you don't have a Win8.x DVD you can obtain a free enterprise evaluation ISO from Microsoft. Assuming you have access to another working PC that is!

Burn ISO

  • I was able to get Windows installed using an old PS/2 keyboard (and a lot of frustrations with a dual hard drive system). Once Windows was installed, all the USB ports work fine, including the ones on the front of the case. They also work fine in the BIOS. Is it still possible that there could be a problem with the board, and not just a disagreement between old tech (win7, 2009) and new tech (Z97, 2014). I'd rather not have to completely disassemble the system, but I also want a working motherboard – ewok Dec 12 '14 at 18:41
  • btw the dual hard drive thing was a totally separate issue. – ewok Dec 12 '14 at 18:41
  • As I see, It happened because these usb ports were USB 2.0. – fx-kirin Apr 1 '17 at 0:47
0

I have a Gigabyte G1.Sniper B5 and had the same problem, setting this:

Legacy USB = Disabled
EHCI Pre-Boot Driver = Disabled
XHCI Pre-Boot Driver = Disabled

did the trick and usb mouse and usb keyboard (logitech mk120) got recognized

  • For the benefit of newbies who may find your answer, can you expand it a little to explain where and how to do this? Thanks. – fixer1234 Feb 28 '15 at 22:41

protected by Community Feb 14 '16 at 13:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.