20

I have a current version of VirtualBox 4.3.20, but after the latest Windows 7 update on Dec. 11th, 2014, it cannot open any virtual machine. First, it would not open the program at all. After a reboot, it would say:

STATUS_OBJECT_NAME_NOT_FOUND

Driver is probably stuck stopping/starting. Try 'sc.exe query vboxdrv' to get more information about its state. Rebooting may actually help. (rc=-101)

The log file says:

b28.146c: supR3HardenedVmProcessInit: Opening vboxdrv stub...
b28.146c: Error opening VBoxDrvStub:  STATUS_OBJECT_NAME_NOT_FOUND
b28.146c: supR3HardenedWinReadErrorInfoDevice: NtCreateFile -> 0xc0000034
b28.146c: Error -101 in supR3HardenedWinReSpawn! (enmWhat=3)
b28.146c: NtCreateFile(\Device\VBoxDrvStub) failed: 0xc0000034 STATUS_OBJECT_NAME_NOT_FOUND (0 retries)

I've tried installing an older version (4.3.18) as well, reinstalling the current version several times, rebooting, uninstalling antivirus software, but nothing helped.

7
  • 16
    You may get the same error on a bad virtualbox upgrade (e.g. left it running when upgrading). Try sc start vboxdrv and if that fails find C:\Program Files\Oracle\VirtualBox\drivers\vboxdrv\VBoxDrv.inf right click and select Install and try again
    – KCD
    May 28 '15 at 19:39
  • The comment above was the solution for me.
    – Hugo Sousa
    Sep 27 '15 at 19:21
  • The comment above was the solution for me too. Jan 15 '16 at 9:36
  • same here. I just did on cmd sc start vboxdrv and now I can use my VM. Make sure to run cmd as administrator, otherwise it won't work. thank you @KCD you saved me
    – samayo
    Feb 26 '16 at 11:05
  • 1
    @KCD anwser helped me too, IMHO not a duplicate of the KB3004394 thread Apr 24 '17 at 15:38
12

You have to remove the Windows Update KB3004394 (or install this update, which apparently just removes the old one). The whole procedure is explained here.

After uninstalling that update, also uninstall VirtualBox, restart, then install VirtualBox, restart again.

Apparently others have had this issue too. The update seems non-critical and should cause no security issues when removed:

The Windows Root Certificate Program enables trusted root certificates to be distributed automatically in Windows. Usually, a client computer polls root certificate updates once a week. After you apply this update, the client computer can receive urgent root certificate updates within 24 hours.

For others, the problem may be caused by using custom themes (i.e. with a patched theme DLL). This could be fixed by running sfc /scannow, but it did not apply in my case.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.