3

I have a .xlsm file that has ActiveX control button with a module macro assigned to it. Problem is I can't click the ActiveX button from my Excel 2010 Standard. I tried to repair and reinstall Excel but that did not fix it. Tried adding a new ActiveX control to the worksheet but got "Cannot insert object" message. Any idea what's is going on?

UPDATE: I checked as many of the security settings as I could based off Google searches, but that didn't seem to work. The icon of the excel file does have a ! sign on orange background though.

SOLUTION: Uninstallting latest Microsoft Office updates solved the issue. I was uninstallting Office updates 1 by 1 until I uninstalled a big one - Service Pack 2 for Office. After a required restart the ActiveX button started to work. Thank you, ajs.

-1

The latest Windows update killed it. Back out the ones involving Excel and VBA and it will run again.

  • I'll give it a go. – user398350 Dec 12 '14 at 15:28
2

The offending update is KB2553154.

The KB article lists known issues with this Security Update including the Cannot Insert Object error message when attempting to interact with a Forms ActiveX control in an Office document. A resolution for the issue is described in KB3025036.

The resolution is to delete cached versions of the control type libraries, which means delete all files named MSForms.exd from the %TEMP% folder and all subfolders.

  • 1
    Thank for this, was banging my head against a wall trying to figure it out. I delete the .exd files C:\Users[user.name]\AppData\Local\Temp\Excel8.0\MSForms.exd C:\Users[user.name]\AppData\Local\Temp\VBE\MSForms.exd and started Excel again and it was fine. Thanks Microsoft for another great patch! – user403990 Jan 2 '15 at 20:57

protected by Community Jan 29 '15 at 22:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.