1

I've got a Sager laptop that for whatever reason, every time I press caps-lock it'll bring up this little window in the upper left telling me it's been turned on/off.

This is a HUGE problem since it takes focus off of whatever form I'm in... I can't type for a second after pressing it, and if I'm in a game and accidentally press it it'll freaking minimize the game and put me in windows to display this dumb notification.

I've switched off the toggle keys options, hunted around Ease of Access Center, Keyboard, and Display settings, and can't find anything to fix this.

Google research showed a bunch of people modifying registry entries in Wincomm or something like that in the local machine/software, but I don't have that subdirectory everyone mentions, so I don't know how to shut the stupid thing off.

Anyone know where to look?

3
  • So for clarification you've tried: Press WinKey and type "regedit" > navigate to HKEY_LOCAL_MACHINE > SOFTWARE > Widcomm > BTConfig > General > KeyIndication Change the value of "KeyIndication" from "1" to "0"Reboot.. – New-To-IT Dec 12 '14 at 17:56
  • Most likely there is a process on the taskbar that is responsible for that and you could disable that (more or less the equivalent of Microsoft's itype.exe). If there isn't any such thing on the taskbar, search your processes online until you find the keyboard controller. – Doktoro Reichard Dec 12 '14 at 17:57
  • Correct, I've tried Press WinKey and type "regedit" > navigate to HKEY_LOCAL_MACHINE > SOFTWARE > Widcomm > BTConfig > General > KeyIndication Change the value of "KeyIndication" from "1" to "0"Reboot. But there is no Widcomm in my Software registry. I'll try hunting through my processes for the keyboard controller... – Arvandor Dec 12 '14 at 18:01
2

It's a utility put on by Sager named the "Hot Key Utility". Go get a newer version from them, and hopefully it doesn't cause applications to lose focus. Or just uninstall it from your system to get rid of it completely.

3
  • Yeah, I saw the HKey Utility and was trying to find some kind of options or settings, but it doesn't seem to have anything aside from choosing what kind of keyboard you're using... I'll try to uninstall it, see what happens. Hopefully it doesn't break anything too badly haha ;) If so, I'll try to reinstall the latest driver, thanks. – Arvandor Dec 12 '14 at 18:12
  • Aha, yes! Uninstalling the hotkey thing seems to have fixed it, excellent! And near as I can tell hasn't broken anything either... – Arvandor Dec 12 '14 at 18:14
  • Hotkey utilities are just crapware. I had a different problem for which I posted a different question, but the answer is the same. I uninstalled my HP crapware – usr-local-ΕΨΗΕΛΩΝ Jul 29 '20 at 20:52
2

Just found a simple fix without uninstalling the utility:

In the taskbar notification area, look for the icon and right-click it. You will see OSD with a check next to it; simply uncheck it and you won't be bugged by those notifications again!

1

For the record:

HKEY_CURRENT_USER/Software/hotkey -> ShowOSD REG_SZ "1": Change to "0"

1

Just in case anyone is coming at this in 2019, I had the same issue on my PC Specialist UK laptop, which came with the CLEVO "HotKey" application pre-installed for the backlit keyboard, etc.

The symptom was an annoying CAPS LOCK ON/OFF notice, which appears top-left of the screen whenever the CAPS key is pressed.

CAPS LOCK ON notice

In the version of Control Centre I have (part of HotKey), I can right-click on the task bar icon and toggle OSD:

OSD option

I can only assume "OSD" stands for "On Screen Display".

EDIT: Sorry, I just noticed @Irvin Lim already provided much the same answer. I should have checked all the replies before posting!

1

I removed the CapsLock popup by disabling HkeyTray on startup.
Use Win+R and type:

"MSCONFIG" -> Startup -> Uncheck or disable HkeyTray.

0

I got a fix from Sager tonight.

Grab your driver CD and copy the Hotkey folder to your Desktop and remove the disk. Open oem.ini from the Hotkey folder in a text editor. Search for the line osd=1 and change it to osd=0. Save the file.

Uninstall the Hotkey Driver from your machine (under Programs and Features, it's labeled Hotkey x.xx.xx with the version number in place of the x's). Restart your machine.

Open the Hotkey folder on your Desktop and run the Setup.exe application to install the new driver. Restart again.

Your problem should be fixed!

0

A WORKING SOLUTION FROM TRUENOTEBOOK.COM FOR LENOVO COMPUTERS AND MAYBE SOME OTHERS USING WINDOWS 8 & 8.1

** If you cannot find EnergyManager in registry, try searching for ENABLE OSD as two separate words or ENABLEOSD as one word or SHOW OSD or SHOWOSD. To search for a setting in Registry, press Ctrl + F3. This worked for my LENOVO Y70-70 17" FHD gaming laptop. Yes, I am happy to play games using 17" IPS screen or sometimes connect to 27" Acer FHD monitor for a big-screen experience.

0. Restart your computer, and after you get to the Desktop, keep tapping the Caps Lock button. See if you get a pop-up allowing you to turn the notification off. If you don't get the pop-up, follow further steps.
1. Press the Windows Menu Key + R button (OR CLICK ON WINDOWS BUTTON AND SELECT AN APP NAMED "RUN")
2. Type "regedit" and press Enter
3. Click Yes to continue
4. Navigate to HKEY_CURRENT_USER / Software / Lenovo / Energy Manager.
5. Double-click on NotShowMsgAgain.
6. Change the value from "01 00 00 00" to "00 00 00 00".
7. Click Ok, close the Registry app and click onto Desktop.
8. Try to click Caps Lock once or a few times and see if notification is still there. Caps Lock repeatedly after you get to the desktop and the pop-up with a question should appear asking you about notifications. Choose "No Thanks".
9. Try to restart and see if notification is appearing or not. Hopefully, you will not have to deal with this annoying problem again!
*THIS SOLUTION WAS POSTED BY MICHAEL.*  


 I have the same issue with my Flex 3. But i can't find the NotShowMsgAgain under energy manager. Is it called differently? *THIS SOLUTION WAS POSTED BY ANONYMOUS USER.*

If you follow what Michael instructed, and get to #5 and can't find that line, look for "enable OSD" and change that one to zeros.

This worked for my LENOVO Y70-70 with Windows 8.1 after looking all throughout the net for maybe 2 hours and trying anything I can and every place with settings throughout control panel and registry searching for hotkeys, caps lock, num lock yet no results were found. Could have been easier, but oh well. Now it is solved. So, after changing regedit entries, especially the one asking to change setting for "EnableOSD" from 01 00 00 00 into 00 00 00 00, but also change NotShowMsgAgain to same values because these solved the problem. Thank you to them.

I hope that this will help you also, because it worked for me, but if you cannot find EnergyManager in registry, try searching for ENABLEOSD as 1 word or ENABLE OSD as two words or SHOW OSD or SHOWOSD. To search for a setting, press Ctrl + F3.

I wish you success with this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.