1

I use a third-party external keyboard with my MacBook Pro. It's a ThinkPad USB keyboard with Trackpoint(I love having control of the mouse pointer without having to move my hands off the keyboard).

Just one problem: one particular key combo doesn't work. In a text editor, option + shift + right-arrow should highlight the word to the right of the cursor, something I use all the time in programming. But it does nothing. I know it's a problem specific to the keyboard and not to a particular app, and I also know it's not a simple hardware problem:

  1. Right-arrow works (moves cursor one character to the right)
  2. Shift + right-arrow works (highlights the character to the right of the cursor)
  3. Option + right-arrow works (moves cursor one word to the right)
  4. Option + shift + LEFT-arrow works (highlights the word to the left) so it's not that this keyboard generally can't handle two modifiers at once;
  5. Option + shift + right-arrow works on other keyboards (e.g. my cheap Logitech K120) on the same computer and text-editor app (so it's not a system- or app-level keyboard-shortcut-configuration issue)
  6. Update: It turns out that Option + RIGHT-shift + right-arrow works (all the above were tested with left-shift). Unfortunately that's a more awkward hand position for quickly moving your selection point around the screen. Maybe if I found a way to swap the mapping of the two shifts....?

I've observed this on two different MBPs (one bought in 2010 running OS 10.6.8, the other in 2014 running 10.9.4). Some intensive googling turns up nothing as specific as this problem. Has anybody observed and solved a problem like this?

Update:

I should have mentioned that I use System Preferences->Keyboard to map the keys printed with "Alt" (closest to the spacebar) to Command, and the "Windows logo" key to Option, so that the layout is most like a mac keyboard.

If I swap back (Windows logo = Command, Alt = Option) then the problem is simply reversed: now I can do option + shift + right-arrow (select to end of word) again, but not command + shift + right-arrow (select to end of line). So the problem is specific to the Windows-logo key location, not to the logical role of Command/Option.

There's no right-hand counterpart to the Windows logo key, so no right "Option". There is, however, a right-hand shift key: see point 6.

  • not an answer, but have you tried left/right shift or alt, in case something is really very key specific? I only have a standard Mac keyboard & it works fine here in all the apps i've tried. Are we talking standard Mac Toolbox-aware apps, TextEdit, Safari etc? – Tetsujin Dec 12 '14 at 21:03
  • Yes, it happens in all standard apps. I mostly use TextWrangler but the same set of phenomena happen in TextEdit, Safari, Chrome, even the Finder when renaming files. And yes! I hadn't thought of the right-shift key: see updated point 6. – jez Dec 12 '14 at 22:44
  • Cmd & Ctrl seem to be interchangeable for those select commands [ctrl/shift/arrow etc). Any joy using the other? … not that that will help the left shift issue. – Tetsujin Dec 13 '14 at 8:24
  • The problem seems to be specific to the Windows Logo key on the keyboard, which occupies the physical position of "option" on mac keyboards and which I therefore map to option. I'd prefer not to re-map my keyboard shortcuts at the user-preferences level since that would make typing on my mac a different experience from typing on other people's macs (which is something I have to do quite often). – jez Dec 15 '14 at 3:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.