27

I'm using FileZilla to connect to my SFTP server. But when I'm trying to connect, it gives me this error

Error: Disconnected: No supported authentication methods available (server sent: publickey)

I have generated a private key with PuTTYgen and added it to FileZilla but this error still appears.

What does this error mean? And how can I solve it?

10

The error means that FileZilla tried all available authentication methods and have not succeeded. In your case, there was only public key authentication method available (a method that the client [FileZilla] and the server agreed on mutually).

As you claim that you have set up FileZilla correctly, chances are that you have not configured the public key on server-side.

For instructions see:

Though actually all the guides expect that you have a way to connect (e.g. password authentication). What does not seem to be the case. Possibly your server administrator/hosting provider has its own mechanism for setting up the public key authentication.

If you specify, what is your server like, you may get more specific answers.

8

I had similar issue error was Error: Disconnected: No supported authentication methods available (server sent: publickey)

Ans: Simply go to filezilla-Edit-settings-sftp-Add key file--add your ppk file-ok

connect again and issue resolved

3

Diff answer than 5 other answers here above (as of this moment)

I received this authentication error- No supported authentication methods available (server sent: publickey) repeatedly while connecting to my google cloud project and connecting thru FileZilla, even when I had spent hours checking my every step again and again by watching diff youtube videos and reading articles over Digital Ocean and similar.

But finally succeeded in a second, when I went into GCloud> Desired Project> Compute Engine> Metadata (in the left bar)> Metadata (in the main Pane)> and there I changed ' enable-oslogin' from 'True' to 'False'.

I had, sometime in my overzeal, had put in this key yesterday while doing something else.

1

I had the same problem and managed to solve the issue.

When using filezilla and sftp, it is important that you have full permissions for the folder where the ppk file is

Easiest way is to save the ppk file in the USER\your_user_name\Documents folder. You may need to set permissions manually for other locations.

1

In my case I found that the FileZilla configuration I had was using an outdated user name for password authentication.

1

Filezilla SSH - cPanel Instructions

Set Filzilla to SSH/SFTP using the site manager.

Set to use authorisation by Key File

For me I had to go into cPanel and then create a key. REMEMBER your password you need it in a minute.

Then "authorize" my key.

Convert your key to PPK in cPanel. You need your password.

Download it & save it somewhere you remember.

Use the Browse option in Filezilla SFTP settings and then upload it.

Then I also had to change my "username" in Filezilla from id_rsa to my cPanel account name. After that things worked well.

As an additional note, instead of using my remote directory as /public_html/ which I would for FTP I had to change it to the full directory /home/YourCpanelUserName/public_html

Hope that that helps someone.

0

This just happened to me, if it was working fine before updating FileZilla then just fix it by deleting your site from your site manager (CTRL + S) and recreating it.

enter image description here

Apparently that update will not take your old configuration files properly.

  • This didn't work for me. It never asks me for the password for some reason. – Eoin Oct 1 '19 at 15:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.