0

I am trying to get an Omega sub-theme running on my local machine (OSX 10.10) with Acquia Desktop Dev. Trying to run isolated ruby in sub-theme directory. When I use rvm list I get:

Warning! PATH is not properly set up, '/Users/khrysztov/.rvm/gems/ruby-2.1.5/bin' is not at first place,
         usually this is caused by shell initialization files - check them for 'PATH=...' entries,
         it might also help to re-add RVM to your dotfiles: 'rvm get stable --auto-dotfiles',
         to fix temporarily in this shell session run: 'rvm use ruby-2.1.5'.

rvm rubies

=* ruby-2.1.5 [ x86_64 ]

# => - current
# =* - current && default
#  * - default

I am not sure of the state of my .bash_profile. It looks like this:

PATH=“/Users/khrysztov/.rvm/gems/ruby-2.1.5/bin:/Applications/Dev\ Desktop/drush:/Applications/MAMP/Library/bin:/Applications/MAMP/bin/php5.5.18/bin:/Applications/MobileDeveloper/adt-bundle-mac-x86_64-20130729/sdk/platform-tools:/Applications/MobileDeveloper/adt-bundle-mac-x86_64-20130729/sdk/tools:/usr/local/bin:”


    export PATH
    export "DRUSH_PHP=/Applications/Dev Desktop/php5_5/bin/php"

    export PS1="\[\033[36m\]\u\[\033[m\]@\[\033[32m\]\h:\[\033[33;1m\]\w\[\033[m\]\$ "
    export CLICOLOR=1
    export LSCOLORS=ExFxBxDxCxegedabagacad
    alias ls='ls -GFh'

    source ~/.profile

    [[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm" # Load RVM into a shell session *as a function*

Bash window is starting like this:

-bash: /Users/khrysztov/.rvm/rubies/ruby-2.1.5/lib/ruby/gems/2.1.0: is a directory
khrysztov@khrysztovs-iMac:~$ /var/folders/bx/936smxc92dg_3pnf0zswj_f40000gn/T/DevDesktopConsole

When I look in Finder at /Users/khrysztov/.rvm/gems/ruby-2.1.5/bin there is an alias (called 'ruby-2.1.5@global' that links to /Users/khrysztov/.rvm/rubies/ruby-2.1.5/lib/ruby/gems/2.1.0 and that has a few gems in there. I did have RVM working before previously but as I was setting up drush it stopped working and I reinstalled and I am worried I may have conflicting files or PATH entries?

0

If you just want that particular warning to disappear just add the following line to your .bashrc or .bash_profile.

export PATH="$PATH:$HOME/.rvm/gems/ruby-2.1.5/bin"

Now just source the bashrc/bash_profile and the message will not appear again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.