2

At some point I was trying to remove the firefox extensions Kaspersky automatically adds (running KIS 2013). Not because they were slowing my browser down, they weren't being loaded anyway (version incompatibility issue), but because I like to keep my browser clean.

The extensions seem to be "global" so I figured I could try removing the directory they are in. Which turned out to be "C:\Program Files (x86)\Kaspersky Lab\Kaspersky Internet Security 2013\FFExt".

When I tried to remove it, I got an Access Denied, so I shut down Kaspersky and tried again, same result. Then I looked at the permissions and it turned out System is the owner. So I started a cmd and did "psexec -s -i cmd" to get a cmd as system, but same result. The folder nor the files are being locked by another process (checked with Process Explorer).

The folder properties say that SYSTEM and the local Administrators have all rights, CREATOR has none and SYSTEM is the owner. I also tried to take ownership of the folder and I tried to give myself permission, neither worked and returned with another Access Denied.

So I'm stumped, how is it possible to create a directory on a Windows machine which System can't even remove? Without having a handle on it. Am I maybe missunderstanding how "psexec -s -i cmd" works? It's Windows 7 Home Premium, SP1 with UAC turned off.

The fact that removing the directory may or may not actually get the extensions removed from my browser is beside the point. It's just to give some context.

0

Kasperski installs a device driver that blocks deletion of those files (to protect itself from viruses altering the files and to do its "quarenteen" function). If you can't run the uninstaller, reinstall the program then uninstall it the normal way. That should remove the device driver.

  • That doesn't really solve the problem. I'd like to keep Kaspersky installed since it's still the best AV I've ever ran. I just want to remove the FFExt folder to clean up Firefox. However, thank you for pointing out that it's the probably the device driver blocking the deletion. – Vincent Dec 15 '14 at 6:20
0

Trying out this tool, this should remove anything what you're not whant.
This program name is unlocker, and this program can remove anything which has close bit element.
The name not help it too much becouse you can get telephone unlcoker search result or something like this, so it this time this program can be available in here:
http://www.filehippo.com/download_unlocker

  • While this might theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. External links can disappear or be unavailable, in which case your answer would have little value. – fixer1234 Dec 13 '14 at 23:38
  • Yes, you're right, this is a very bad habit which came from my blogger past :) I edit my answer, thanks for your improvents. – Neo Dec 13 '14 at 23:45
  • @Vincent - Scott Chamerlain's answer indicates that Kasperski does some heavy-duty stuff to prevent deletion, which might make file unlocking as performed by tools like the one in this answer ineffective. For the benefit of others with the same problem, if you try one of the file unlocking tools, could you comment here on the results? – fixer1234 Dec 13 '14 at 23:58
  • I would actually not recommend using Unlocker, as in recent years they've come under fire for including adware in their installer that tends to install anyways even if you decline installation. Consider using LockHunter as an alternative to Unlocker. – int_541 Dec 14 '14 at 5:45
  • @fixer1234, will do when I get a chance. – Vincent Dec 15 '14 at 6:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.