1

I am getting regular hangs on my windows 7 machine imedietly after installation and after updating drivers. The machine is a Dell XPS 15 (L521x).

It happens approximately once every few minutes. Sometimes I can move the mouse but can not click on anything and sometimes I can click on some applications but not others. It will also hang when staring an installer and when right clicking to get a context menu. When I press CTRL + ALT + DELETE it will not respond for several seconds until it suddenly jumps to the CTRL + ALT + DELETE screen. When I dismiss this screen, everything catches up with what it was doing and inputs inputed during the hang start working. Also sometimes CTRL + ALT + DELETE will work and only a couple of applications freeze, always including chrome.

I ran a couple tests with Windows performance analyser to try and record what happens when it hangs. The first time I found that disk usage went straight up to maximum and stayed there for the duration of the hang. the second time WPA gave me an error opening the trace because there was not even enough bandwidth to record the trace properly! when ignoring the error the second trace showed the same story. Interestingly for each trace a different program had the highest service time.

Windows Event Viewer shows "Service Control Manager" errors when opening installers. Also there are "Microsoft-Windows-WMI" Errors with event data

//./root/CIMV2 
   SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99 
   0x80041003 

I have also run chkdsk which returned no errors.

I have no idea what is causing the hangs but I was previously running Ubuntu on this machine with no problems so I am assuming it is not a hardware problem, in fact I specifically installed Ubuntu to get away from the hangs. I thought I would give windows another go but I will need to resolve this problem for it to be any use.

  • this eventview entry can be ignored. which HDD do you use? – magicandre1981 Dec 14 '14 at 7:03
0

I am getting regular hangs on my windows 7 machine immediately after installation and after updating drivers.

I think that's the answer. It sounds like problem with drivers. You've got service tag, right? Download newest drivers from Product support and please update the BIOS. And if you have a SSD drive please make optimisation of Windows in that direction. Plus go to BIOS and make sure that your system is running in AHCI mode.

  • I have updated to the latest drivers and updated the BIOS which I have set to AHCI. The SSD software on the support page "Intel Rapid start" will not install because apparently my computer does not meet the minimum hardware requirements (even though it clearly does). Also I ran the dell hardware test and it says there are no problems. – koreus737 Jan 2 '15 at 16:23

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.