1

I'm running into a no audio problem on the latest version of Linux Mint (Rebecca). I've uploaded the data to here for anyone to peruse, and hopefully find a solution to this problem: http://www.alsa-project.org/db/?f=eb88fccc3b81bce46687669cc5033df1abf1f42c

The computer in question is a newer model Toshiba Satellite.

pactl list sinks
Sink #0
    State: SUSPENDED
    Name: alsa_output.pci-0000_00_1b.0.analog-stereo
    Description: Built-in Audio Analog Stereo
    Driver: module-alsa-card.c
    Sample Specification: s16le 2ch 44100Hz
    Channel Map: front-left,front-right
    Owner Module: 4
    Mute: no
    Volume: 0:  80% 1:  80%
            0: -5.94 dB 1: -5.94 dB
            balance 0.00
    Base Volume: 100%
                 0.00 dB
    Monitor Source: alsa_output.pci-0000_00_1b.0.analog-stereo.monitor
    Latency: 0 usec, configured 0 usec
    Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
    Properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "ALC284 Analog"
        alsa.id = "ALC284 Analog"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "0"
        alsa.card_name = "HDA Intel PCH"
        alsa.long_card_name = "HDA Intel PCH at 0xf7c10000 irq 50"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:1b.0"
        sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "8c20"
        device.product.name = "Lynx Point High Definition Audio Controller"
        device.form_factor = "internal"
        device.string = "front:0"
        device.buffering.buffer_size = "65536"
        device.buffering.fragment_size = "32768"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Analog Stereo"
        device.description = "Built-in Audio Analog Stereo"
        alsa.mixer_name = "Realtek ALC284"
        alsa.components = "HDA:10ec0284,1179f941,00100001"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    Ports:
        analog-output-speaker: Speakers (priority: 10000)
        analog-output-headphones: Headphones (priority: 9000, not available)
    Active Port: analog-output-speaker
    Formats:
        pcm

3 Answers 3

2

Sometimes the desired sound output source (or "sink" using the sound setup terms, I think) isn't selected.

Linux Mint 18 should still use pulseaudio as 17 does.

Have you selected that card (or tried everything listed) in the Sound Settings under output? (on xfce it's accessible by clicking on the sound/volume icon in the toolbar indicator plugin, other DE's should be similar)

Or use the terminal and the pactl command could do about the same thing:
pactl list sinks should show your available outputs ("sinks"), and
pactl set-default-sink [name] should set one as default, using the Name: from above.

3
  • Tried, has no perceivable effect. Curiously, it is stated as SUSPENDED...don't know if that means anything. Dec 14, 2014 at 20:45
  • suspended is what mine say too, probably means "no sound right now" or something. Has sound ever worked on any Linux/Ubuntu, or windows for that matter?
    – Xen2050
    Dec 14, 2014 at 20:54
  • Windows, yes it has. Though I am growing more curious by the hour if I was imagining that. Dec 14, 2014 at 20:59
0

Tried a reinstall of the drivers, and the headphone jack seemed to work. Opened the laptop case, and the speakers came back to life.

0

I had the same problem. I use linux mint 17.1 rebecca, I think. My laptop is lenovo. I googled and looked on various sources. When I enter pactl list sinks code on terminal, it gives me 2 sinks, and both of them were suspended. I tried to set default sink etc., no way, there was no sound on my laptop. There is volume control on menu (start) bar, so I changed devices from there and tried again and again, restarting etc. And finally sound is fixed and working now. And when I enter that above-shown pactl etc code I still get both sinks suspended. So I suggest you to try to fix it with "Volume control" settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.