17

I am currently configuring a Thinkpad E540, having inserted a 256 GB M.2 SSD into the corresponding slot, in order to run Windows 8 from the SSD instead of using the preconfigured 16 GB SSD as a cache for the hard drive.

All was well at first, but now any attempt to install software will result in the error message

Windows API error 302: This volume is too fragmented to complete this operation.

Needless to say, on an SSD fragmentation shouldn't be an issue. I tried running the drive optimization tool of Windows 8 (which defragments HDDs, and sends TRIM commands to SSDs) but it helped only briefly (so briefly actually, that it might have been mere coincidence that there was any effect at all).

Any idea what might be causing this?

*edit* Some new insights that I have gained since:

  • Rebooting temporarily removed the issue. Running the optimizer tool is not required.
  • It reappears after some time.
  • Note that the drive has 140 GB of which only 60 GB have been used. Trim shouldn't be an issue yet!
  • On the other drive E:, also on the SSD, I have not seen the issue yet.
  • Moving data to the C: drive works fine under Linux.
  • Even echo test > test may fail on C: (in the home directory)
  • Even reading the event log may fail at that point.
  • 5
    Regarding "fragmentation shouldn't be an issue": it still happens on SSDs; it's just that fragmented files can be accessed as quickly as non-fragmented ones, so you don't get the performance degradation that you'd get from fragmentation on a hard drive. – Wyzard Dec 14 '14 at 23:07
  • 2
    Is it coming up for all software? – Canadian Luke Dec 14 '14 at 23:14
  • 2
    Restoring Windows 8 from an image created with ntfsclone has solved the issue, so I think it may have been a failed update. – kdb Dec 16 '14 at 11:12
  • 1
    I read that defragmenting SSD's is very bad for it. Therefore I advise against it. – AdmiralAdama Dec 16 '14 at 14:48
  • 1
    There is a Hanselman blog post about fragmented SSDs, the conclusion is that defrag is also needed for SSD's – Cerveser Dec 17 '14 at 14:46
2

I restored Windows 8 from an image. Afterwards the issue didn't show up again. My best guess would be a botched update, or permission issues after copying AppData files from the old disk, with the fragmentation warning being a possibly misleading symptom of the underlying issue.

By suggestion I post this as an answer, though I'd still be interested to know if there are other ways to resolve such issues, or what could have caused it.

  • That seems possible. I was trying to install the Insider Preview update on Windows 10 when this happened. Not sure if this also has something to do with dualbooting with Linux though. – xji Jan 27 '18 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.