0

I'm not able to connect to a WIFI using a cloned MAC address. I tried with 2 different access points, with the internal WIFI and with an external WIFI.

After cloning to a valid MAC address (took from a list of addresses assigned to vendors), I time out when trying to connnect.

This happens if setting the MAC address via the network manager and when disabling it and setting it up on CLI.

Anyone has any ideas about what could be wrong?

5
  • Can you connect successfully to anything, with any mac? Possible hardware/driver issue – Xen2050 Dec 15 '14 at 5:52
  • If I don't clone the address, I'm able to. It happens with 2 interfaces, I don't think it makes sense to be a driver. – Linux User Dec 15 '14 at 6:17
  • True, that should rule out one possible problem. So if your computer end appears to be working (assuming the cloning MAC addresses is successful, and doesn't break something) I'd look at the other end - does the AP not want those MAC's to connect, or only allows your original MAC? – Xen2050 Dec 15 '14 at 6:21
  • But the weird thing is that I tried with 2 different APs, of different brands and models. All I can think of is that maybe the range I used is not for WIFI interfaces, so the AP is rejecting them? But it makes for both to have that validation, does it? – Linux User Dec 15 '14 at 6:49
  • I'm not sure if AP's only accept certain "ranges" of mac's... tried cloning a mac from another device that can connect successfully (with the other device off/disconected? Probably more trouble with 2 of the "same" device trying to connect) – Xen2050 Dec 15 '14 at 6:57
0

It is a well-know problem, see this launchpad bug report. It has something to do with network-manager, if you connect manually to the ifi AP (i.e., without network manager) it works flawlessly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.