I'm trying to install MySQL Community edition on a Windows 8.1 machine. To sum up the problem: whith the .msi installer I get MySQL registered as a service, but unable to start (error 1067); with a manual install I get the service running but the console gives back a 10061 error when checking for server functionality.

My question here is if anyone has familiarity with this kind of problem in Windows 8.1 and can hint to a solution or at least figure out which may be the problem.


This is a much more detailed explanations of the same facts:

I encountered a problem with the configuration of the MysQL server, the server has installed and it is running in the Windows services, but the installation prompt stops at the "Starting Server" step of configuration. The log reads: "Stop servce. OK. Set service. OK. Set firewall. OK. Start service ..." then it just stops there giving messages that signals that too much time is passing.

If I try to manually start the service from services.msc I get a 1067 error (process terminated unexpectedly). If I interrupt the configuration and try to proceed with the wizard I get a page wich list the MySQL server as installed but stopped and I can't establish a connection with the password I set up.

I may try to change the default port, but the configuration log says that nothing is wrong with the firewall. I tryed to do all of this from the Administrator account and the behavior is the same.

Then I tried to install the server manually from the Administrator account and eventually got a running service, but this is what I get:

..\bin>mysql --install MySQL56 --local-service (and subsequently: ..\bin>mysql --install MySQL56) Service successfully installed. (The service is listed in services.msc as an automatically managed service).

..\bin>mysqlshow msqlshow: Can't connect to MySQL server on 'localhost' (10061)

..\bin>mysqlshow -u root mysql msqlshow: Can't connect to MySQL server on 'localhost' (10061)

..\bin>mysqladmin version status proc mysqladmin: connect to server at 'localhost' failed error: 'Can't connect to MySQL server on 'localhost' (10061)' Check that mysqld is running on localhost and that the port is 3306. You can check this by doing 'telnet localhost 3306'

..\bin>mysql test ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)

and I'm kind of unsure how to run that telnet command. anyways, since I'm trying to access the localhost I don't see how there could be problems with the data getting throught the port.

I found some general advice on some Chinese BBS with users who had the same errors, but none of them has been particularly useful (deleting my.ini, manually set localhost to 127.0.0.1, etc,).

  • Can you please confirm whether MySQL service in services.msc is running and also if possible update the output of the following command by running in the command prompt netstat -an | find "3306" – vembutech Dec 15 '14 at 7:59
  • I feel stupid now. I saw "automatic" in the services.msc interface and assumed that it was already running. it wasn't, now it is. I'm sorry, it has been three hours since I started troubleshooting this and I'm reading a Chinese interface.. – maja Dec 15 '14 at 8:09
  • btw, I ran the netstat command and didn't get any output, what should that command do (maybe I should have asked sooner..)? – maja Dec 15 '14 at 8:09
  • after starting the service netstat finds the 3306 port connections without problems of sort. – maja Dec 15 '14 at 8:17
  • OK,Is it possible to access MySQL now. – vembutech Dec 15 '14 at 8:27
up vote 1 down vote accepted

To run the MySQL in the command prompt,please follow the steps

(i) Open the command prompt and use the command cd C:\Program Files\MySQL\MySQL Server 5.6\bin.

(ii) Now run the exe mysqld.exe.

You would be able to connect the mysql.

  • The solution is in the comments at the orginal post: making sure that the service has started after it has been registered. – maja Dec 16 '14 at 5:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.