0

I need Internet Explorer 9 for developing. So I go here and I can download it only for Windows Vista and Windows Server 2008. However when I try to install I get the error (translated):

This version of IE install program doesn't support this version of Windows.

How can I fix that?

  • @Ramhound I have IE8 – iJava Dec 15 '14 at 20:32
  • Also by pressing F12 in IE11 and clicking the computer/tablet icon you can emulate IE 5/7/8/9/10. – Chris Dec 15 '14 at 20:38
  • @Ramhound No. As I think it will try to install IE11 – iJava Dec 15 '14 at 20:38
  • @Ramhound Do you mean I should enable windows auto update? – iJava Dec 15 '14 at 20:42
1

After some research on the web I found the offline installer download link of Internet Explorer 9 for Windows 7. And the localizations download link.

Also be sure to check and install the Internet Explorer 9 prerequisites.

|improve this answer|||||
  • Thank you!!! It's working. This (bad words) microsoft do everything in order we hate it. I can't upvote your answer as I don't have here enough reputation. Thank you again. – iJava Dec 15 '14 at 21:03
  • You're welcome. By the way Microsoft isn't that bad ;) – Chris Dec 15 '14 at 21:05
  • You even can't imagine how many hours of my life I wasted because of this ... company products such as IE8 etc. – iJava Dec 15 '14 at 21:07
  • @PashaTurok - You could have just used the free VM that Microsoft provides with IE9 already installed. – Ramhound Dec 15 '14 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.