2

When i save a .psd to a Photoshop PDF, some fonts don't look like they looked in Photoshop. They are not completely filled like they are in Photoshop. See the attachments:

This is how it looks in PhotoShop:

And this is what it looks like in, for example, google chrome's PDF reader.

As you see, there is a white area in the font. How do I fix this?

  • How does it look in Adobe Reader? You might also open the PDF in Acrobat Pro and check about overprinting. You may also need to flatten the image when creating the PDF; that should take care of overprint/knockout effects. – Max Wyss Dec 16 '14 at 9:24
1

I have found a possible solution on the forum of Adobe. Adobe forum link: How do I embed fonts in PDF? The 1st reply from (g_ballard) is the one you could try out. Credit for the answer goes to him, I only searched the forum for possible answers.

In short (I've copy-pasted his answer onto here, if you don't want to go to the forum):

Option #1:

Merge all your pixel layers (leave your font layers intact)> File> Save As: Photoshop PDF

Be sure to uncheck General> Options: Preserve Ps Editing Capabilities (or your files will be monsters)

Open in > Acrobat, Resave

Option #2:

Select Type Layer> Layer> Type> Convert to Shape

1

Fixed:

  1. Click Save As.
  2. Select PhotoShop PDF in the dropdown-list.
  3. Uncheck Layers
  4. Check Embed Color Profile.
  5. Check Use Proof Setup.
  6. Check As a Copy.
  7. Click Save.
  8. Uncheck All checkboxes in the General window.
  9. By Presets, Select PDF/X-1a:2001
  10. Click Save.

Done!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.