3

Users usually can download portable software and use it from local drives withount any warning. (I mean small executables just as putty.exe or a portable application from PortableApps.com)

However when starting such files from a network location windows usually show security warnings.

Unsigned exe file file warning: "The publisher could not be verified. Are you sure you want to run this software?"

Zip File: "These files might be harmful to your computer.... "

These warnings can sometimes appear even when starting files from local drive. This is regulated by Zone.Identifier hidden files which can hold information about the origin of the file. Such files are created by webbrowsers.

However in case when no such file is present windows decide whether to show this warning according to the location. (Depending on wheather it is local drive or network drive.)

And now to the question: Broken back up program changed something on my drives which maked them behave as network drives. Where are these settings stored?

I tried reinstaling windows (several times). I formated C drive and 100MB boot partition. But that doesn't help much. My C drive now behaves normally. But my E, D volumes still behave as network drives. Note that other volumes which hadn't assigned drive letters during that problematic back up also behave as local drives.

Besides of reinstalling windows I tried changing permissions and owners of the files on E and D drives so they are the same as C.

Note that PortableApps doesn't start from D and E even after clicking Run in that warning. They show NSIS Error: "Error writing temporary files. Make sure your temp folder is valid."

Is there a way to change the security zone of specified drives without formating them?

0

How to eliminate the “Open File Security Warning” from programs accessed from the file server.

Open the Control Panel
Open Internet Options
Click the Security Tab
Click on Local Intranet
Click on Sties
Click Advanced
Type the drive letter of your file server where the application is located in the “Add this website to this zone” box. 
Click Add
Click Close
Click OK
Close Internet Options by clicking OK
Close the Control Panel 

You should no longer get the “Open File Security Warning” when you run an application from the file server.

source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.