19

I recently got a 64GB USB stick and planned to make it a system repair multitool, with different Linux and Windows installers and live images, but I seem to have a USB stick that cannot be booted.

Pendrive Linux' Yumi installer doesn't recognize it, and only lists it when "show all devices" is checked.

YUMI, not checkedYUMI, checked

The Windows 7 USB install tool doesn't recognize it either.

Windows 7, USB tool

When putting an image on it with either Yumi or diskpart and xcopy, none of the three PCs I tested are able to boot it, but none of them have problems booting from another smaller, slower 8GB drive. The HP USB format tool, as mentioned in this answer does format it, but that does not enable bootability. I have tried both NTFS and FAT32 filesystems, but neither succeed.

What causes this? I was under the impression that USB sticks are just storage devices (like optical discs) and that it was enough to have the correct files/structures to make it bootable. Is the device missing some critical feature necessary to make it bootable?


Additional Info:

The mainboards of the PCs are the GA-MA770T-UD3 (AM3 socket, probably a bit old), the GA-Q87TN (1150 socket), and whatever is inside the Dell XPS12 9Q33. The latter two run Haswell processors with UEFI, I can't imagine that a 64GB stick would pose a problem.

I also tried formatting with the Windows tools, and tried to make a partition of only 20GB.

  • That is odd, I've never ran into this issue! I've always used diskpart and set the partition as Active and that was enough. – Lee Harrison Dec 17 '14 at 16:46
  • 2
    Apparently somebody else's had this problem, too. It looks like there are some flash drives that just can't be booted from. – iFreilicht Dec 17 '14 at 16:50
  • 1
  • @Ƭᴇcʜιᴇ007 interesting questions and good answers. Unfortunately, neither solve my problem nor do they answer my question. If it is true that the bootable flag has to be set in order for windows to recognise multiple partitions, then it is set on my drive as I tested it with two partitions, and both could be read from and written to without error. – iFreilicht Dec 17 '14 at 17:00
  • Does Windows give you the Eject option for that drive when it's plugged in? – Ƭᴇcʜιᴇ007 Dec 17 '14 at 17:09
8

Just want to share my experience. We burn a lot of bootable ISO's to flashdrives to setup anything from Windows server series to Windows 7 through 10. We ONLY have issues with Kingston drives when it comes to this. I spoke to a guy at tech support from Kingston and after a lot of useless info it basically boils down to its not guaranteed to boot. So i tried all the other troubleshooting options like diskpart, full formats and even the linux way of partitioning and formatting. So several days later i checked my bios and as always the USB disk shows as a harddrive like any other brand of USB disk. I noticed there was a note in the right hand page to "press N" to remove the Kingston USB disk as a "harddrive" which will then mark it as a removeable disk. After pressing N the disk disappeared from the harddisk list and i save/rebooted. It works perfect now!!! This wasnt necessary for any of my other USB disks which booted perfectly every time on various hardware platforms except for my Kingston G3 and Fury 3.0 drives.

Hope this could help some other frustrated techie :D

3

Some usb stick manufacturers factory partition drives with tables not suitable for creating a bootable drive. Formatting makes no difference as it does not affect the tables, just erases the contents of the primary, visible partition. (I had issues with a "reputable" brand before with this issue.)

If you have access to a Linux box, plug the drive in, find what Linux names the device as then run:

dd if=/dev/zero of=/dev/sd***  

(change *** to the device name given)

This wipes the drive completely (by filling it with binary zeros), file system, PTs the lot. So make sure you specify the correct device!!! Then reformat (FAT32 is better as UEFI doesn't support NTFS) and you should be good to go.

  • Don't use cp, use dd. I'm not sure what cp will do in this case but it may simply destroy the device node (and turn it into a blank file filled with zeros) instead of writing data to the drive. – user256743 Dec 19 '14 at 21:42
  • Thanks for catching that, I just noticed what he said and was about to freak out D: – hanetzer Dec 19 '14 at 21:49
  • 3
    cp won't destroy it. It copies zeros to the drive, where as dd will delete existing content and write new zeros. Same result with a slightly different way of getting there I guess. Both ways are valid. In fact cat would work to. – Chris Kennett Dec 19 '14 at 21:50
  • Does that mean I could also use the "create partition table" feature of GParted? – iFreilicht Dec 21 '14 at 0:24
  • Nevermind, GParted didn't work. Unfortunately, your solution didn't work either. The drive was deleted completely, including the partition table. But after reformatting, the problems all persisted. – iFreilicht Dec 21 '14 at 1:39
2

I dealt with this problem with my SanDisk drive and the only solution for me was to purchase another drive. Check your drive in the "This PC" menu of your computer. Flash drives usually show up as a removable disk. This information about this drive being bootable or or is usually contained within the flash drive itself. Here is mine, for example: picture of this pc menu.

To protect users from destroying their entire hard drive, Microsoft and other disk burning utilities limit themselves to only being able to burn onto so-called "removable" disks- USB drives, CDs, DVDs, etc. What happened is that some companies (one of them SanDisk) sold misconfigured flash drives with the bit for being removable off. I'm not too sure how exactly this information is stored, but as far as I know there is no way to change the firmware. You'll have to purchase a new flash drive, or alternatively, you may be able to convince the company to give you a refund/replace your flash drive.

Sources:

  • I'm a new user so I can only post 2 links per post, so here's the link to a Google search with a ton more to read: click here – umop aplsdn Dec 24 '14 at 22:27
  • I think you might be on the right track. The drive does indeed show up as "local disk". The stick was a present from my Dad and I don't really want to bother him with returning it, I don't think he even has the receipt. – iFreilicht Dec 25 '14 at 23:28
1

This is pretty old so maybe you found a solution but for anyone who finds this later, I am posting an answer.

The USB firmware may be the problem. You can update the firmware of a USB device, which may resolve the problem. Here is a link that enumerates various SWs to do so: http://wiki.openmoko.org/wiki/USB_DFU_-_The_USB_Device_Firmware_Upgrade_standard

1

There is a downloadable program called BOOTIce at www.ipauly.com that I have used to make a Lexar 16Gb bootable that Rufus couldn't. Works a treat! I am no real techy-type person so don't know all the ins and outs of how it does it but it handles the MBR which other pgms haven't been able to. I highly recommend it to solve the problem of a stubborn no boot stick. (I'm not a sponsor nor do I receive a commission for bringing this to your attention...LOL)

  • BooiICE is the best... lots of funcionality beyond partitioning... also handle MBR(s), PBR(s), BCD create/edit, VHD(s), ... – ZEE Sep 25 '18 at 11:08
0

This is only a semi-educated guesstimate, but might help someone one day.

I just spent the last 90 minutes failing to boot a 2007 Advent 4211 from USB, to no avail.

I'd been using unetbootin to create the bootable USB stick.

Speculatively, I think the partition size was causing the incompatibility. The symptom was nothing but a flashing cursor on the screen when booting. I instead followed Mint's "hybrid" ISO instructions (simply dd the ISO to the USB stick's raw disk) and that worked.

As I say, this is speculative, but I'm guessing the 64GB partition was playing sillies.

  • This is really a comment and not an answer to the original question. – DavidPostill May 13 '17 at 13:26
  • Deleted. All yours. – wally May 14 '17 at 18:51
-1

To be honest I recommend against such automated usb makers, one can often do exactly the same with standard GNU/linux tools, eg dd, grub and syslinux (and there are windows ports of said tools.)

But, to answer your question, it could be a number of things. Perhaps the tools in question are not designed with the idea of a 64gb usb stick in mind, perhaps the maker of said stick does something unusual to the disk to make it appear as something other than a standard usb stick.

To tell you the truth, knowing what I know now about linux, I'd just man up and burn something to a cd/dvd as a staging ground for the multiboot usb stick. If windows can't handle the job, then what is a single cd to you if you can make it do what you want it to?

Shameless plug, if you're looking to make a bootable windows7 usb stick I have a pretty popular answer on askubuntu.

  • I'm not sure what you're recommending. Is your proposed solution to this problem to use a CD/DVD? Because that is absolutely impractical, my pants are not designed to hold CDs in their pockets. Also, what does this have to do with Linux? And, did you read a bit about the software I used? Because Yumi uses the exact Linux tools you described, just with an easier to use front-end. – iFreilicht Dec 21 '14 at 0:16
  • 1
    I'm recommending burning to a cd/dvd to have a usable linux userspace to create the usb, not expecting you to carry the cd around with you. And front ends are more of a pain than what their worth; if they do something wrong and the backend doesn't act properly it makes it a bit harder to debug, instead of just reading what stderr has to say about why it broke. – hanetzer Dec 21 '14 at 6:28
-2

The question is "what makes a drive bootable?" Most usb drives are formatted FAT32. This has a MBR (master boot record) which hold the partition info. This can be more than one. The problem is that most OS's (operating systems) cannot see more than one when on a usb drive. For a usb drive to be able to boot it must also be set active. The standard OS format routine is not designed to do this. So a more specialised formatting application is required to do the job. One such application which I have had some success with is WinSetupFromUSB. This is intended to create a bootable usb drive from an installation CD/DVD. However, it also contains three formatting applications which can be used from within the main application. The three in question are FBinstTool Bootice (mentioned in Brewster reply) and RMPrepUSB. As these are full programs in their own right, if you can find them on your hard drive, you can create links to run them directly from the desktop. Needless to say, these are all Windows based applications. Another Windows based application which might be useful is SDformatter by Panasonic. It is intended to wipe clean and reset SD memory cards, however it will also do USB memory sticks. There are from the same family of technology. Apart from the usual quick format option, there is a full erase and re-size option. The risk, as with all low level formatting techniques, is that there is a possibility of making the USB memory stick unusable. Having wiped clean, you can then set about reformtting with say RMPrepUSB which has a number of boot & format options. RMPrepUSB can also recognise a USB stick which does not appear in the explorer.

  • 1
    So a more specialised formatting application is required to do the job. I disagree, I have done it using cmd and no other applications. – RogUE Dec 28 '17 at 2:13
-2

I had the same issue "black screen with flashing cursor" even though my new SanDisk USB drive was marked active and the same bootable material was copied from a known working bootable USB stick. My fix was as follows:

  1. Run CMD as Admin
  2. Launch DiskPart
    a.) list disk
    b.) select disk 1 (or 2 or whatever your USB drive disk number is)
    c.) clean
    d.) create partition primary
    e.) list partition
    f.) select partition 1
    g.) format fs=ntfs quick
    h.) active
    i.) exit
  3. Copy your bootable material to the now empty drive USB drive.

protected by Community May 11 at 19:01

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.