I installed Windows 10 on my laptop and everything works great. Except when I take it to meetings and plug into a projector, nothing shows up on the projector and my screen blinks madly between all black and a grayish screen where I can kind of make out the mouse cursor.

I understand that Windows 10 is alpha/beta... what steps can I take to troubleshoot this problem?

Here are some facts:

  • Resolution: 1366x768
  • The projector worked fine when the laptop was Windows 8.1
  • The graphics card is Intel HD Graphics Family (whatever that means)
  • The driver is from May 2014, so reasonably recent and I don't see any updates.
  • The Device Manager is all good, except for 1 item marked Other Devices -> Unknown Device (can't figure out what it is - Details tab doesn't really give any info).
  • Did you try different resolutions? Could you add to the question what the method of connection to the projector is?
    – Psycogeek
    Dec 18, 2014 at 19:19
  • 2
    What you describe is handled by the display driver. This sounds like a display driver bug.
    – Ramhound
    Dec 18, 2014 at 19:19
  • @Psycogeek The method of connection is the HDMI cable. Dec 18, 2014 at 19:32
  • If it is possible to do so try a resolution of 1280x720 , I do not know but in desperation that would be my first attempt.
    – Psycogeek
    Dec 18, 2014 at 19:39

2 Answers 2


The Fact that your graphics card is identified as Intel HD Graphics most likely means that Windows 10 cant find a driver for it. You can:

  1. Right click > properties > update driver online.
  2. Go to the manufacturer website and try the most recent driver.
    • You could install in comparability mode by right click the install exe if they don't have a driver for Windows 10 yet, which I'm sure they don't and wont

Pretty safe to say that your graphics card is integrated on an Intel mother board. If you need to view your hardware in Windows 10 go to All Apps > Windows Administrative Tools > System information.

I personally prefer using an application like PC Wizard.

  1. Go to "My Computer"
  2. Try to disable the built in-video card
  3. Enable the external video card
  4. Restart
  5. Go to "My Computer"
  6. In "Properties," disable the external video card
  7. Enable the built-in video card
  8. Enable the external video card

(It's all automatic detection.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .