3

[I asked this question on Overflow and they closed it saying it belongs here. Hope that's correct.]

My basic problem: I have horrible latency. When pinging google.com I get average round-trips of 48 seconds (yes SECONDS not milli-seconds). Similarly bad ping rates occur going to other sites. This happens on both wired router connections and wireless router connections.

The problem only occurs if I use my router. IMPORTANT DETAIL: If I attach my Mac Pro directly to the cable modem everything works great on my Mac (40 ms ping rate to google.com). In this situation it seems to not matter how long I wait, it just keeps working.

If I reboot the router or renew DHCP on the router itself I get decent ping rates (40 ms range) for about 45 seconds and then it goes back to behaving badly. In that 45 second period I can also get a quick traceroute.

Once approximately 45 seconds are up ping starts to fall apart and traceroute drags to a crawl. Some traceroute hops cannot be negotiated (I just get * * * as an answer).

When ping responses do return they come through all at once as though they are stacking up somewhere. And then they stop again.


Things I've tried after consulting various Interwebs Oracles:

  • New patch cable
  • Installed DD-WRT firmware
  • Setting MTU lower to avoid fragmentation problems (though I never saw any fragmentation problems)
  • Disabling QoS (in truth it wasn't turned on)
  • Cloning another device's MAC (like the MAC from my Mac Pro desktop).

I would sure appreciate any pointers anyone might have.

  • 2
    Is the router under warranty? Sounds like it could be faulty. – James P Dec 18 '14 at 22:30
  • 2
    Is it only ping or anything is slow after 45s? Do you have any firewall rule filtering ICMP? – laurent Dec 18 '14 at 22:33
1

Thanks for the comments. I found the problem in a totally unexpected place. First the answer:

The culprit is Google Drive syncing through my router.

When I shut down Google Drive or bypass my router my bandwidth returns.


The rest of this answer contains more details; you may want to skip but some like to hear them:

[Sidebar puzzle: I do not have to turn Google Drive off on my Mac Pro when I directly connect to my cable modem. The problem only happens when my MacBook connects Google Drive through WiFi or my MacPro is wired to the router. I don't understand. I supposed there is something about routers that are not necessarily friendly to File Syncing. BTW, this is also why it made me think the problem was with the router.]

I found the answer by several steps. A web search suggested that the problem might be a particular device. I nearly locked out all the devices but my wife interrupted and said everything was working fine. I began fuming when I realized my Netflix device (Roku) was shut off at that time. You see, I began to whip up conspiracy theories about TWC throttling my bandwidth because I use Netflix (LOL). We watched Amazon Prime with no problem and I was convinced of my theory!

However, just now I sat down at my laptop and suddenly pings went south again. It dawned on me that maybe it was my laptop and I began to poke around looking for bandwidth hogs. Google Drive and DropBox both fit the bill. I ran them both one at a time and DropBox did cause some latency, but not bad. A little research and I discovered that DropBox has automatic throttling built in. Google Drive does not. When I turn Google Drive on, all heck breaks loose. I had ping running on my phone and you could watch the ping rates rise like I was flipping on a switch.

You may wonder why would Google Drive suddenly start causing issues? This is because my current fileset to be synced is larger than I typically sync, but only for now. I suspect that when the sync is completed the issue will go away.

The most recent comment I've heard from Google Drive devs was 2012 when they said throttling was planned but not yet implemented. I'm not sure when it will go in.

Again, thanks everyone!

  • UPDATE 2 years later Google Drive now has throttling built into the settings. This is no longer an issue. – user25986 Aug 30 '16 at 15:00
0

Start by checking your firewall rules,, and see if you have ICMP filtering rules on - that does affect pings.

Next, check your router - it might have diagnostic tools which can have the router itself ping sites and such. See if there are such tools and then use the tools to try and replicate the problem. If they are replicated at the router itself, check if there's network restriction rules in place on it. If not, and the dd-wrt firmware didn't help, then perhaps the issue is faulty equipment. Check if the equipment is under warranty, and see if you can get it replaced. If it is not under warranty, you may need to get a replacement router. (This is based on you saying the issue happens with the router connected but not she hooked directly into the modem, which suggests a issue on your side and not the network service itself.)

0

I was having a similar problem with my tp-link router. Unfortunately, it has no open-firmware compatible. The ping to my router from any wireless device was reaching 9 SECONDS which was causing problem in internet speed.

What I have done is that I opened router settings and changed my wireless standard from 802.11 b/g/n to 802.11 g. Till now the problem has disappeared and the ping to my router is now < 2ms which is making a good experience using the internet! I've read that in 802.11 n standard:

Use of multiple signals may interfere with nearby 802.11b/g based networks.

Although I don't have many networks (~ 5) in my range, but interference could be the problem. Now, all is working fine!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.