When I try to update a driver via the device manager, windows 7 tells me that

windows has determined the driver software for your device is up to date

even though I know that mine is newer (due to the version number), and refuses to install it. Is there some way to override this behavior and force windows to install the newer driver?


I had a similar issue recently with a video driver. What I did was install the standard VGA driver, rebooted, then re-installed the driver I needed.

I would suggest that you try manually selecting a driver and if that doesn't work, you can choose to show compatible devices or all... try showing all and selecting a driver that is older or for a similar but different piece of hardware.

Then try to install your desired driver.

alt text

alt text

alt text

  • This was apparently the only way I could roll my Hauppauge Colossus driver back after an update made the card unstable. Even if I uninstalled it, then installed the older driver, Windows (7 64-bit) would override it with the newer one. Also pointing the wizard to the driver installation path didn't work but the "Let me pick" method did. Thank you! – jimp Apr 28 '13 at 2:54

If your version of Windows 7 is not Home, you can use the method in the following article:
How To Disable Automatic Driver Installation In Windows 7, then delete the device in Device Manager, reboot, and install your driver.

Create a system restore point before you start these manipulations, so you can go back if things go wrong.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.