Trying to use KiTTY with Cygwin (x86) on Windows 7 x64.

  1. Installed latest Cygwin and all needed packages.
  2. Added ;c:\cygwin\usr\local\bin\;c:\cygwin\bin to system Path env.
  3. Downloaded KiTTYCyg for Cygwin 1.7 form here: http://www.9bis.net/kitty/?page=PuTTYCyg and unpacked it to KiTTY dir.
  4. When I'm selecting "Cygterm" as connection type in KiTTY and using "-" as command, I'm getting this error in terminal window:

    /bin/sh: No such file or directory

    And if using something like "mosh" as command, getting this error:

    mosh: Permission denied

Please help me to find a reason.


That message is caused by because the the cygwin1.dll that came with KiTTYCyg is for Cygwin 1.7, but you're probably using a different version. Delete it. Replace with a copy of the one in c:\cygwin\bin (or add c:\cygwin\bin to your path, etc).

If you're using Cygwin64, you'll need to replace cthelper with cthelper64 as well.

  • Thanks for your answer, but it's not working for me. I replaced cygwin1.dll and got same errors. When I'm replacing cthelper with cthelper64, I'm getting "failed to run cthelper". – Roman Ovchinnikov May 5 '15 at 5:18

Make sure you're running the latest version of KiTTY ( at the time of this writing), since it adds extra features to detect Cygwin treats (like 64 bits and its install path).

What worked for me was to copy cthelper64.exe into C:\cygwin64\bin and edit kitty.ini adding this:

[Cygwin integration]

Then in your KiTTY Configuration window you need to add a dash (-) in the Command and select the Cygterm radio:
KiTTY plus Cygterm

Probably you may also want to check that Cyterm branch in the setup tree and adjust accordingly: KiTTY left tree with options

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.