I have, not one but two microSD cards that my phone (Samsung Galaxy Young, Gingerbread OS) seem to have broken. One is 1GB and the other is 2GB. The 1GB one won't be formatted.

When I put the 1GB one into the computer the computer prompts for a formatting. I don't care for the content so I tried to format it, but to no avail; the format fails and I have no idea what to do to make it work again.

I tried using the SDformatter software, but it can't format the card as it is write protected. I'm googling to solve it but so far no success.

My computer OS is win7 if that's of any relevance.

  • Try from microSD adapter, or other PC, device. – Davidenko Dec 19 '14 at 14:35
  • It may not help, but, try using SD Formatter. It's made to format sd cards. – rrirower Dec 19 '14 at 14:35
  • I am using an adapter to put the microSD card into the computer. I'm trying the SD Formatter as we speak, but it can't format since the microSD card is write protected. – Gemtastic Dec 19 '14 at 14:41
  • The adapter may be the culprit. See this link: techchannel.radioshack.com/… – fixer1234 Dec 19 '14 at 14:49
  • The very same adapter successfully formatted my 2GB microSD card, and I have a USB hub for various cards that I'm using. This hub also get the write protected error when I try to format it with SDFormatter. – Gemtastic Dec 19 '14 at 14:56
up vote 23 down vote accepted

Golden Rule #1

As soon as an SD card [or USB stick] starts to play up - bin it. They're not worth the effort once they error.

I go through literally hundreds of them for work. Low write count, high read count.

If they error once, they will error again. Quality control on them is, let's say… variable.

Some of them have a controller chip that will permanently lock them to read only if they detect a write error, as a preservation measure. There is no way to unlock them once this happens.

Golden Rule #2

Don't use them to store anything valuable.

Edit:
If the data on an SD card was truly valuable, it is theoretically possible to replace the controller chip, or even directly access the memory itself. This service can be performed by data recovery specialists, but they charge a lot for their efforts & still can make no guarantees.

Rules 1 & 2 are still 'best practise'

  • I noticed the hard way rule n0.2 since I had fairly irreplaceable pictures of my diseased dog. 'tis a bit annoying if it's broken; the cards came with the phone and neither card has been in use for even a year. I don't even use the phone very much... – Gemtastic Dec 19 '14 at 16:34
  • rule 2 is very unfortunate if you have to find out the hard way, sorry. You might be able to scavenge the cards for files, using Recuver or similar, but I'd give up on trying to get them to reformat. they're cheap & disposable, & break with alarming frequency. Mean time to failure only means that the average card will last as long as it should, some will die in a week, others seemingly go on forever. – Tetsujin Dec 19 '14 at 16:39
  • …contd… Of the possibly 5000 cards I've dealt with this year, maybe 50% have shown no errors, 10% went back to the factory for analysis, the other 40% limp along, sometimes erroring, sometimes OK [They are not used in critical situations so a couple of glitches we can get away with] These are, btw, very cheap cards. Retail branded cards ought to have better figures than that. – Tetsujin Dec 19 '14 at 16:41
  • Although what you're saying is probably true, I still hope to find a way to try and fix my microSD card, if it is fixable. I'm on super user for a reason, you may understand that I want to fix things, not just throw them away like disposable junk, even though it may very be exactly what it is. – Gemtastic Dec 19 '14 at 18:04
  • 4
    if it's switched to write-protected, that's it. End of life. No fix. If it hasn't then it will attempt to reformat - if it finishes in a few seconds, fine, if not, bin it. Either way, attempt to recover first. – Tetsujin Dec 19 '14 at 18:28

My friend faced a similar problem with his pendrive, although it was a little bit different, it was related to write protected and my friend find the below method( I do not know whether it worked or not), if you are interested, give it a try at your own risk.

  1. Open Start Menu
  2. Run, type regedit and press Enter, this will open the registry editor.
  3. Navigate to the following path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies
  4. Double click the key WriteProtect in the right pane and set the value to 0 In the Value Data Box and press OK button 5.Exit Registry

You should remove it as below:

  1. Pull the USB flash drive out of your computer's USB port. Check the bottom end and sides of the drive to see if it has a write protection switch. Push the plastic switch into the "Unlock" position.
  2. Insert the USB flash drive back into the USB port. Close the pop-up window that appears and navigate to the Start menu. Select "My Computer."
  3. Locate the drive letter that corresponds to your USB flash drive in the "My Computer" window, such as "F:\" or "D:." Double-click the drive letter. Attempt to use one of the files on the drive. Right-click one of the files if you still receive a write protection error and select "Properties."
  4. Navigate to the "General" tab and remove the check mark from the box labeled "Read-Only." Click "Apply" and then attempt to use the file.
  5. Return to the Start menu and click "Run." Type "Regedit" and press "Enter." Navigate to the registry folder "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies."
  6. Check if there is an entry at the right side of the window labeled "Write Protect". If the entry is not there Right-click inside the window and choose "New D Word." Type "Write Protect" and press "Enter."
  7. Double-click the "Write Protect" entry. Check that the value listed in the text box is "0." If it is not, delete the value and replace it with "0."
  8. Close the registry editor and attempt to use any of the files on the USB drive. Return to the "My Computer" window if you continue to receive a write protection error message.
  9. Right-click the drive letter for the USB flash drive and choose "Format." Click the drop-down menu named "File System" and select "Fat32."
  10. Click "Start" to format the USB flash drive and remove the write-protection feature

    I have told you that it's for pendrive, make appropriate changes whenever it requires.

  • I tried this, but it didn't work. :/ It may be useful for someone else with my problem searching for an answer though. – Gemtastic Dec 19 '14 at 17:11

For Widows: Use DiskPart in the terminal

The following will wipe the disk, and you will have the ability to format the disk to it's full capacity (provided that the disk is not faulty).

  • Open a terminal as admin

  • Type: "diskpart" and run it

From DiskPart:

 DISKPART> list disk  
 DISKPART> select disk {disk number} //example: "select disk 3"
 DISKPART> clean
  • Exit DiskPart
  • Open "Create and format hard drive partitions" from the Start menu.
  • Format your disk.
  • I encountered this problem trying different distros for raspberry pi. Windows does not like the Linux image creation, for some reason. – Bradley Nielsen May 7 '17 at 7:19

protected by Community Jan 31 '16 at 19:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.