1

I have a Dell Latitude E6530, running Windows 8.1, with a Broadcom 802.11n Network Adapter. I am able to connect to my phone's personal hotspot, but not my home wifi. The home wifi router is a Google Fiber router, running at 5/2.4 ghz. The message I get when attempting to connect is "Can't connect to this network." The Windows troubleshooters don't find anything wrong. If I disable the security on the router, I'm able to connect to the router, but I have no Internet connectivity.

All of the other devices in my house are able to connect without a problem. Any ideas are much appreciated.

Updated.

  • You mention Wifi, but have given me the name of a gigabit ethernet adapter which isn't wifi, but wired. Can you confirm your wireless card please? – JohnnyVegas Dec 21 '14 at 1:21
  • How embarrassing! I've updated the question with the correct information. – threed Dec 22 '14 at 16:46
1

I probably should have thought of this earlier, but the answer was simply to update the driver for the wireless card.

0

Try manually adding a wireless profile with the wireless settings from the router. Quite often the wireless wizard in windows fails to detect the encryption, so manually adding a wireless profile gets around this.

  • Sadly, this didn't work, despite ensuring that the manually setup profile had the exact same security (WPA2-Personal) as the router. – threed Dec 27 '14 at 21:29
  • Try all the other security methods. WPA, and WPA2. Don't use WEP as it's totally insecure. If still no joy buy a cheap USB wireless adapter and try that. One minor thing - try connecting to the router a room or two away. I did have a router once which TX rate was too high and I could only connect doing this. – JohnnyVegas Dec 31 '14 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.