2

I have a question about router configuration that I haven't really found an answer to.

What I have:

SSID: House A: A ZyXEL DSL-modem (660 Prestige) with built-in WLAN and DHCP-Server. IP: 192.168.1.1 SSID: House B: A Asus RT-something router, which I've set the IP to 192.168.1.2. No DHCP.

What I want:

Two SSID:s, House A, and House B. But on the same network. House A has the WAN-connection.

Configuration: I haven't managed it to work yet, but this is how I've planned to do it so far:

The ZyXEL set to 192.168.1.1 as mentioned, and the ASUS to 192.168.1.2. Disable the DHCP-server on the ASUS, and connect them to eachother via LAN 1 on both devices. The ZyXELs' DHCP Pool already starts at 192.168.1.10. Subnet mask 255.255.255.0 on both.

My question:

Is this a correct configuration to do what I want? Will the ZyXEL assign IP's to both routers clients, and will the clients in both houses work on the same network? And can I access both routers, on both networks, using their IP-addresses?

Also, if this is bad practice, please let me know why. I really want to use different credentials and SSIDs if possible.

Extra:

If I for some reason want to separate the networks in the future, is it enough to just set different Subnet Masks, or should I enable DHCP on the House B router? WAN is still only available from house A.

  • FYI, unless your time is worth nothing, why not just get a router that supports a "guest" wireless network> – Debra Dec 21 '14 at 15:27
  • Both mine does, but the range between the two routers is the problem. For some reason I can't even make the second router work as an access point. I'm starting to think that something in the ZyXEL P-660 prevents the ASUS RTN12D1 from getting an IP and access to the Internet :( That's why I in the beginning thought it was a piece of cake to just hook up the other ruouter to this one, but it doesn't work even as an extension of my current network, or as its own. – swaglord mcmuffin' Dec 22 '14 at 2:29
1

That looks like it will work - One configured as the main with DHCP, and the other simply an access point with different SSID. Make sure firewall is switched off on the ASUS. Make sure that the ASUS has 192.168.1.1 for gateway/dns. Some routers don't behave properly when used like this so if you still have problems get a dedicated wifi access point for house B, configured in exactly the same way.

  • For some reason the ASUS refuses to find a way to reach the Internet, leaving me with a limited connection in House B. Firewalls are disabled in the ASUS. Nothing works. Tried to set the ASUS back to 192.168.2.1, to create a new network behind the ZyXEL, but it doesn't get any WAN access at all. Really weird. Everything works on the ZyXEL, and I thought that the ASUS would just act as like what-ever-other-device, get an IP, and then start assigning IP's to it's own network. The WAN port shouldn't be used at all, if the other device is a router, right? – swaglord mcmuffin' Dec 21 '14 at 13:33
  • The ASUS must accept the DHCP from the ZyXEL - Try connecting the ZyXEL to the WAN port of the ASUS then setting the IP in the wan section to 192.168.1.2/255.255.255.0 gateway 192.168.1.1 and same for DNS. This setup isn't ideal but should work. Make sure DHCP and firewall are turned off on the ASUS. Anything now connected to the LAN ports of the ASUS should now get their DHCP address from the ZyXEL. – JohnnyVegas Dec 22 '14 at 16:46
  • Nice one! After disabling the IPv6 firewall, NAT and everything it actually connected to the ZyXEL, but with no Internet access so far. But this is a great victory so far, so I'll keep on trying! I'll update this thread and mark it as solved, as soon as I can manage it to work. Thanks alot :) – swaglord mcmuffin' Dec 23 '14 at 12:34
  • If no internet - disable the ipv4 firewall, check that the DNS settings for the ASUS is 192.168.1.1 - Doing it this way via the WAN port isn't ideal due to having to use it's DHCP on it's own lan. – JohnnyVegas Dec 27 '14 at 2:02
  • I kinda sorted it out, but by using the WAN port on the Asus, and disable practically everything on it, including all IPv6 features. It works, but the DHCP is weird and doesn't work for all devices, so on those I had to set the IP settings manually :/ But I'm still working on it! Thanks alot for the help! – swaglord mcmuffin' Jan 9 '15 at 11:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.