0

I've got a device (a Ninja Sphere, if you're curious) that does serial over mini-USB. On my Ubuntu laptop, it shows up as /dev/ttyACM0 and when I screen into it, I can log in (it's basically Linux on an ARM chip) and do everything, as if I'd SSH'd into it via the network.

When I plug it into my PC, I get "device not recognised", with a device descriptor request failed error. I'd love to do my screening on my Windows PC, but am not sure how to do it. I tried using PuTTY in serial mode with COM1, COM2, COM3, USB, USB0, USB1 and many other variants, but with no success.

So how does one start a serial connection on a USB device, and how does one do it if it's not showing up as a COM port or something similar?

  • If Windows recognizes it, it should show as a COM* port. – user1686 Dec 21 '14 at 13:39
  • That was my thought too, but it doesn't. I'm not sure if Linux is just pushing past the "no device descriptor" thing and giving me access to the raw USB, or if I'm missing something. – Grayda Dec 21 '14 at 14:02
  • Can you check your Device Manager and see if there is an unrecognised "Gadget Serial" device? – Mokubai Dec 21 '14 at 14:03
  • @Mokubai: It shows up as "Unknown USB Device (Device Descriptor Request Failed)", even after I uninstall it and plug it back in. I've also tried 'forcing' it to be a serial device by trying to specify a device (Update Driver > Browse for Driver > Select device from list) but it's hellbent on showing generic-y USB drivers (e.g. USB hub, Composite USB devices etc.) – Grayda Dec 21 '14 at 14:10
0

For anyone who comes across this question, https://discuss.ninjablocks.com/t/howto-setup-a-windows-pc-to-connect-to-a-ninja-sphere-via-usb/3259 had the answer for me. Basically my machine was missing info on how to describe (use) the device. Downloading https://www.kernel.org/doc/Documentation/usb/linux-cdc-acm.inf fixed the issue, as the file told Windows how to properly deal with the device.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.