1

Here are my specs and details:

  • The monitor is a BenQ GL2450 whose native res would be 1920x1080.
  • The OS is Win 7 x64.
  • The Mobo is a Gigabyte F2A88XM-D3H with integrated Graphics (Radeon HD 7480D).

When I select the 1920x1080 resolution, yet my BenQ immediately reports:

"Nonpreset mode, recommended resolution 1920x1080."

I've installed Catalyst control center, installed the mobo drivers, updated the graphics drivers, nothing helps to solve this.

Windows and Catalyst both report 1920x1080 being set, yet the monitor seems to refuse to go into that mode. In reality the resolution looks to be something funky like 1700x1200, as the right portion of the monitor shows a fat black bar, and the taskbar is half-way cut off. Lower resolutions aren't correct either, having different parts of the screen cut off at times.

It's also listed as a "non-PnP monitor" under hardware manager and refuses to be anything else.

Could the cable be at fault? It's connected to the PC via a VGA cable, the monitor's input says D-Sub. Do I need to use DVI-D instead? Because I just set up this computer for my grandpa and we don't have one here, only VGA, and would prefer not having to buy one if that's not the source of the error.

  • 1
    If you can hook with the DVI than do so. the analog is doing 2 conversions anyway, from the original digital to analog , to the monitor then back to digital for the display engine stuff. Other possibilities is to get a monitor Driver from BenQs site, which is just a profile for the monitor which can include the res it works at, and color calibrations. It is also possible that it is not the res, but also the refresh rate that is selected. When all else fails, AMD usually had a "List All Modes" ability (look it up), which can provide more options (that do not work:-) – Psycogeek Dec 21 '14 at 19:42
  • @Psycogeek the refresh is set to 60Hz. What's also curious is that Catalyst reports a completely wrong EDID (Extended Display Identification Data) of 1920x1200@75Hz, when the monitor is 1920x1080@60Hz in reality. Forcing the correct maximums doesn't help, unfortunately. I tried downloading a GL2450 driver from an external site, since I can't find anything on BenQs site, but Win refuses to take it. – Mhhkay Dec 21 '14 at 19:43
  • 1
    seconded for get rid of the VGA cable – Tetsujin Dec 21 '14 at 19:50
  • Back at the odd wrong resolutions, many analog monitors , and some digital monitors you still had to go into the monitors menu to tell it to "auto scan" or whatever they call it, the resolution and sync settings. so when playing with it, head into the monitor menu also. the sync settings (analog) and "fill" "3/4" and "1=1" settings do not always change themselves. – Psycogeek Dec 21 '14 at 19:53
  • I can't find a link to prove it, but I think VGA maxes out at a much lower resolution. It's very old and quit being updated when other technologies surpassed it. I third getting rid of VGA – Tyson Dec 21 '14 at 20:00
0

The BenQ switches to D-Sub instead of DVI.

Open the menu of the BenQ and choose DVI as input. Then, your Mac will allow to choose the suggested resolution of 1920x1080.

If you are still on D-Sub, the resolution is just too poor. However, the screen will often forget this setting. Unplug the screen, check the correct input setting and try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.