I am using Beaglebone black with NFS,
I have formatted internal eMMC with ext4 filesystem,

when i mount the file system using following command message popups telling filesystem is mounted without journal, so how can i mount the filesystem with journal,

# mount -t ext4 /dev/mmcblk0p2 /media/emmcrfs/
[10639.836647] EXT4-fs (mmcblk0p2): mounted filesystem without journal. Opts: (null)

Another thing i read is ram journal is better for embedded system, is it so ?
How can I set ram journal option ?

Do i have to use tune2fs utility ?

1 Answer 1


well with some experiment i found the answer,

I had used mke2fs /dev/mmcblk0p2 command to format the partition. And after that if i mount /dev/mmcblk0p2 on the /media/emmcrfs mount spits message that it is mounting file system without journal.

when i used mkfs.ext4 /dev/mmcblk0p2 command to format the partition and then mount /dev/mmcblk0p2 i see mount giving message that it is mounting file system with journal. For exact message see below command

# mount -t ext4 /dev/mmcblk0p2 /media/emmcrfs/
[ 3172.107869] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)

So when i googled it i found that mke2fs utility refers /etc/mke2fs.conf file for different options. if mke2fs is not given any argument it takes parameters from [defaults] from the /etc/mke2fs.conf and these [defaults] parameters doesn't have journal option.

When i use command mkfs.ext4 it internally calls mke2fs with ext4 as parameter and because of which mke2fs refers parameters for [ext4] in the /etc/mke2fs.conf. In my case [ext4] contains the journaling option so it creates journal.

Hope it helps someone having same question as me :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.