1

so, I have a base debian install and installed Xorg and awesome on it.

I've been trying to get my keyboard (macbook 2,1) to work properly for a couple of days now. Initially, I had used dpkg-reconfigure to change my keyboard to the qwertz/macbook/de layout. That had worked flawlessly, aside from caveats noted below.

recently, when I rebooted, I discovered that my .Xmodmap file had stopped being read, and also my keyboard layout had become en-US

I can set the keyboard layout to german with setxbmap de, and everything will work, (aside from caveats below). But that is where the issue starts.

macs (and a lot of european keyboards) use a left alt (or alt-gr) as level3 modifier for certain characters. e.g. on OSX leftalt + l is @. I am unable to replicate any such behavior in linux. With dpkg-reconfigure I do have the opportunity to decide which key to use as alt-gr, but selecting left alt ruins the entire layout, printing random chars like umlaut y, as opposed mapping level3 to right super, which actually does work.

So I guess my question is: how can I make Xorg not completely shit itself when I ask it to use left alt as a level3 modifier key?

here's some command output:

notafile@notamac ~> localectl
System Locale: LANG=en_US.UTF-8
VC Keymap: n/a
X11 Layout: de
X11 Model: macbook79
X11 Variant: mac
X11 Options: lv3:rwin_switch

feel free to comment any other files/commands I should give you the output of

1

I run gnome-shell version 3.14.2, and I was able to set Left Alt as a level 3 modifier by going to Settings -> Keyboard -> Shortcuts -> Typing and setting Alternative Characters Key to Left Alt.

  • This does work, however I was at the time on a base debian install, which of course did not have such features – Azsgy Jan 17 '15 at 16:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.