0

I'm trying to write Bluray disks on Ubuntu 14.10 since I bought my ASUS SBW-06D2X-U external USB unit. What happens is that it get exessively slow (0.2-0.3x) and it crashes when it reaches around 1Gb. In k3b software the device buffer oscilates between 21-29% until crashing.

I found some people saying it may be a dma problem but I read other messages saying that DMA doesn't work on USB drives. And also couldn't find any procedure on how to activate DMA. Tried also Silicon-Empire and Brasero but it won't even start to write. K3b has all the programs it needs including cdrtools as seen in K3b configurations. I try to write several folders with about 37GB of data, and try to create the image and write it. Also tried writting the image and burn it with growisofs, and got the same result.

I'm using 50Gb bluray medias and my notebook is a Asus Vostro 3550, I7, 8gb. It has a 120Gb ssd for the root partition and a 1TB HDD where the files that I want to write are saved. I have set K3b to save the image in the HDD.

Edit:

Results to the asked tests:

Downloaded Nero for linux and it had equals results.

Still on 50gb medias:

I tried to write aprox 270MB of data, and it failed again.

Bought 25gb medias and it finally worked. But it took 6 hours and 40 minutes to write a 25gb Bluray.

Now here says it suppport double layer medias and here one customer has written it not only works in linux, as it said that it writed 50gb medias with it:

"Awesome to be able to backup my partitions to 25-50GB discs!"

So I guess it's not drive related. Anyone as tried this in other Linux distribuitions ? I think I'm gonna give it a try on Mint and Fedora.

Edit2:

In other computer (i5, 8gb ram, 500gb Hdd, Ubuntu 12.04 32bits):

Tried to write aprox.40gb directly (I mean without making an image) to a 50gb media with nero and after 2 hours aprox (15% of the burn) nero application crashed.

Successfully burned aprox.1.6gb directly (again without making an image) to a 50gb media with nero. Took apox. 35 mins. So this proves my drive CAN write do 50gb media.

In this moment I'm trying to write aprox 40gb from a saved image. It's the only lacking test. I'll report it's result tomorrow as it will take several hours to finish.

  • Have you tried the optical drive with another computer to see if it behaves the same way? What kind of file(s) are you trying to write to the disk? A disk image, or just a bunch of files? – Ƭᴇcʜιᴇ007 Dec 22 '14 at 17:42
  • Well.. didn't try to acctually write the disks on other computer, tried only mounting it. As I said, I try to write several folders with about 37GB of data, and try to create the image and write it. Both methods didn't work. – Nelson Teixeira Dec 22 '14 at 17:44
  • Edited the question to make this more clear. – Nelson Teixeira Dec 22 '14 at 17:46
  • What happens if you try to burn less data? Like say just 1GB or a few hundred MB, does that work? – Ƭᴇcʜιᴇ007 Dec 22 '14 at 17:52
  • 1
    @davidgo The drive has a USB 2.0 interface: SBW-06D2X-U specs. – Andrew Morton Dec 29 '14 at 18:37
0

The answer to your problem is that the burning tool that is installed by default with k3b cannot write blu-ray disks. You get a whole variety of errors, like the ones that you described. To fix this you will need to install a different version of cdrecord. Instructions for this can be found here: https://help.ubuntu.com/community/CdDvd/Burning

Edit: Shorter version - add the following ppa and programs to replace the defaults using:

sudo add-apt-repository ppa:brandonsnider/cdrtools
sudo apt-get install cdrecord mkisofs

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.