2

I recently inherited a mid 2009 13" MacBook Pro. I wanted to install Ubuntu 14.10 on the machine rather than OS X. I've previously had success with Ubuntu 13.10 on a 2006 MacBook by booting to live USB and installing over the current OS, so I tried this method again with admittedly limited research.

While installing 64-bit Ubuntu 14.10 on the MacBook Pro 2009, everything seemed to go fine. However, when I rebooted the machine in an attempt to launch Ubuntu for the first time, I was greeted by GRUB, selected Ubuntu, and then dropped to a purple screen. Nothing changed after 30 minutes -- still a purple screen. Repeated attempts to boot into Ubuntu 14.10 produce the same results.

In hindsight, it looks like I probably should have installed rEFIt or rEFInd on the machine prior to installing Ubuntu, as the 2009 MacBook uses EFI rather than BIOS. Is this required even when you're not setting up a dual boot?

Thus far, I have tried two routes to solve the issue. First, I tried to boot back to Ubuntu live USB, but to no avail. The GRUB menu appears as usual, but when I select either "Try Ubuntu" or "Install Ubuntu", the screen goes black and hangs there.

My second attempt was to create a bootable USB of OS X Yosemite. This too is getting hung up. When I select the option to load from USB, the Apple symbol appears on the screen with a progress bar. The progress bar has been hung at ~25% for the last 45 minutes or so. I have yet to have the option of installing the OS.

What is the best way to get my machine running again? I would be happy to have either OS X or Ubuntu installed at this point.

EDIT - UPDATE:

I followed the advice of infostacker on AskUbuntu. I plugged in my live USB (Ubuntu 14.10, created on Windows 7 with Unetbootin), hit 'e' on the GRUB menu while the 'Try Ubuntu without installing' text was highlighted, and added to the 'linux' line of the boot command: 'quiet splash acpi=off nolapic nomodeset'. This got me the purple screen that you typically see upon booting Ubuntu with the moving dots (the splash screen?). Once it got past the moving dots stage where you'd expect the Unity desktop to pop up, I was greeted with some text. The final line of text where the system appears to get hung reads:

(initramfs) Unable to find a medium containing a live file system

Here's a picture of the entire screen. I can't embed because I'm a noob.

When I try to run Ubuntu off of the hard drive (i.e. without the live USB) using the same command, I get different results. I get a purple screen that reads like this:

Booting a command list

Loading Linux 3.16.0-28-generic ...
Loading initial ramdisk ...

It hangs on the last step to infinity and beyond.

EDIT - UPDATE 2:

I am able to boot into Ubuntu if I edit the GRUB script. When I append quiet splash with nolapic I am able to boot without issue.

My first move upon booting was to install the proprietary NVIDIA 331 driver, which is the tested driver and claims to be suggested for my system. I then removed the open source driver using sudo apt-get --purge remove xserver-xorg-video-nouveau.

Upon normal reboot, I get stuck at the purple screen again. It seems the only way to boot the system is with the nolapic parameter. What could be the underlying cause of this?

  • Where you installed your boot loader during Ubuntu installation I am having same problem now. I will vote up if you will answer for this. :) – Khamidulla Apr 1 '15 at 10:24
0

If you can get on to OS X, hold CMD+R to get into recovery mode. That is all I know. You can try reinstalling OS X from there (No data loss).

  • I've tried this a couple of times. I think this machine may have predated the recovery partition - it's a mid 2009 model. Thanks for the suggestion. – vitale232 Dec 24 '14 at 19:13
  • Anytime. I did this on my grandmother's iMac since Safari broke. No files left behind! – juniorRubyist Dec 24 '14 at 19:18
  • Oh, hold down Option when turning on. It will show the Mac bootloader. – juniorRubyist Dec 24 '14 at 19:19
  • If I hold in Option on boot with no USB plugged in, I get a gray screen with a cursor, but no options to select. – vitale232 Dec 24 '14 at 19:34
0

Hold down option with the Yosemite USB plugged in, select it from the Apple Boot Manager, and it will boot into EFI and then Yosemite, then open /Applications/Disk Utility.app and click your internal hard drive, select First Aid if it's not already selected, and click repair disk. Let it finish even if it errors, and post the results here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.