A year ago I received a one-year license for ESET Smart Security. Today it was over, and I decided to replace it with a free alternative.

Everything went fine, but one thing. After uninstalling, the ESET Updater (C:\Program Files(x86)\ESET Updater) remains on my laptop.

It wouldn't be a big issue, but it does one thing that I do not wish it to do: it activates a proxy server and enforces it on the system. No matter what I do, I can't disable it. I've tried setting it as an administrator, modifying registry entries manually, and nothing. Nada. It simply does not work.

The proxy server runs locally, on port 8080. Tasklist and Netstat say it is the Updater.exe creating it, and removing it indeed kills the server (and thus, any internet connection). But even after removing every little trace of ESS, the forced settings remain, and I cannot disable the proxy settings.

How can I get rid of it?


1 Answer 1


Couple things you could try:

Once you think you have the files removed, go into IE's options and ensure there's no Proxy configuration (still) set in there.

Short version of their manual removal instructions:

  1. Download the ESET Uninstaller and save it to your Desktop.

  2. Restart your computer in Safe Mode.

  3. Click Start > All Programs > Accessories. Right-click Command Prompt and choose Run as administrator from the context menu.

  4. In the command prompt window type cd Desktop and press Enter

  5. Type EsetUninstaller.exe, hit Enter, and read the warning.

  6. Review the item(s) listed under Installed AV products, type the number that corresponds to the ESET installation in this list that you want to remove and then press Enter.

enter image description here

  1. Verify that you are uninstalling the correct ESET product from the correct operating system.

  2. Once the ESET Uninstaller tool is finished running, press any key to exit and then restart your computer in normal mode.

  • I will try this in a second. Though interesting that in two removals the same script/app that maxes the proxy permanent, remains on my computer.
    – fonix232
    Dec 24, 2014 at 18:08
  • Unfortunately it did not work. In safe mode with networking, I had internet after killing the Updater off, but after reboot, there's the proxy again.
    – fonix232
    Dec 24, 2014 at 18:37
  • Have you tried deleting the Updater.exe file, and searching the registry for references to it (to remove)? Did you check your IE proxy settings to ensure they're not set to anything? Dec 24, 2014 at 18:40
  • As I said - removing Updater.exe will make the proxy server stop working (thus cutting my internet access), and no matter how I try to null the proxy settings, they come back. There's a note on the Connections tab, though, that says that some of the settings are controlled by the system administrator (which would be me, duh).
    – fonix232
    Dec 24, 2014 at 19:00
  • What are the actual settings that keep coming back the IE Proxy options? Dec 24, 2014 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.